Mysql Datasource Issue

Hi all,

i'm getting an issue from with intellij idea 9.0.2 (and 9.0.3) as well, where a previously definied project datasource will not connect to the mysql database to get table, column updates.

The error i get is

java.rmi.ConnectException: Connection refused to host:; nested exception is: Connection timed out: connect
    at sun.rmi.transport.tcp.TCPEndpoint.newSocket(
    at sun.rmi.transport.tcp.TCPChannel.createConnection(
    at sun.rmi.transport.tcp.TCPChannel.newConnection(
    at sun.rmi.server.UnicastRef.newCall(
    at sun.rmi.registry.RegistryImpl_Stub.lookup(Unknown Source)
Caused by: Connection timed out: connect
    at Method)
    at sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(
    at sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(
    at sun.rmi.transport.tcp.TCPEndpoint.newSocket(
    ... 28 more

The settings are correct, as the datastore previously functioned perfectly and the underlying database has not changed. I can't pinpoint exactly when it stopped (i.e was it when i updated idea, etc ??? no idea)
I've also tried removing and readding the datastore, which fails when trying to test the connection.

I'm running the following
idea 9.0.3
mysql 5.1
mysql connector 5.1.12 (have also tried version 5.0.8 and 5.0.4)
windows 7 64bit with ip v6 enabled

I've tried disabiling the windows firewall, playing with network settings, etc but to no evail.... mysql is definitely listening locally on port 3306 and i've tried connecting to localhost, the pc's actual ip and address...

Any ideas would be appreciated as this is becoming frustrating.


Please sign in to leave a comment.