How to get Maven/Tomcat configured to deploy war?

Hi everyone,

I'm a bit new to all this so bear with me. I currently have a project that deploys an ear file to a Weblogic server. This is currently set up under "Edit Configurations" in Intellij where the ear artifact is built and Maven installs it, then Weblogic starts up,  and everything works fine.

However I am now trying to switch to Tomcat 6, and it doesnt accept ear's for deployment. The way I've been doing it for now is I manually startup Tomcat and use the Manager to deploy the war created during the build process; it appears to work fine, so I know that the war being built is ok.

What I don't know is how to setup Tomcat plugin like the Weblogic plugin in Intellij, where one click can start the server and automatically deploy the war. I figure it's some kind of simple configuration that I'm missing here, but like I said I completely new to this so I don't know. Can anyone help?

Thanks!
Tim

1 comment
Comment actions Permalink

Please check that you have a war artifact in the project (File | Project Structure | Artifacts), it should be created by IDEA when you imported the
project from Maven. If so you can specify that artifact in a Tomcat run configuration editor ('Deployment' tab).

Hi everyone,

>

I'm a bit new to all this so bear with me. I currently have a project that deploys an ear file to a Weblogic server. This is currently set up under "Edit Configurations" in Intellij where the ear artifact is built and Maven installs it, then Weblogic starts up,  and everything works fine.

>

However I am now trying to switch to Tomcat 6, and it doesnt accept ear's for deployment. The way I've been doing it for now is I manually startup Tomcat and use the Manager to deploy the war created during the build process; it appears to work fine, so I know that the war being built is ok.

>

What I don't know is how to setup Tomcat plugin like the Weblogic plugin in Intellij, where one click can start the server and automatically deploy the war. I figure it's some kind of simple configuration that I'm missing here, but like I said I completely new to this so I don't know. Can anyone help?

>

Thanks!
Tim

>

---
Original message URL: http://devnet.jetbrains.net/message/5269418#5269418



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.