Data source configuration not working

(New to IDEA, sorry if I'm missing something obvious.)

So far I'm unable to configure a data source successfully in IDEA 902/903.

Test Connection succeeds, and if I don't include a table name in the  connection string, I get the list of all tables from master. However,  providing the correct database name I get "java.sql.SQLException:  Database 'mydbname' does not exist." I've tried the latest microsoft  and jtds drivers, same behavior. This is SQL Server 2008.

Not sure if it's related, but with no db name I can get the master  tables from the Data Source Properties dlg, but when I click OK and  refresh the tables from the Data Sources pane, I get "Incorrect driver  and/or connection setting specified", with the same settings that worked  in the dlg.



Also possibly related, the db name has hyphens in it. Doubt it, but do those need to be escaped somehow in the connection string?


Specs I'm using for jtds are:
   JDBC Driver Class: net.sourceforge.jtds.jdbc.Driver

   Database URL: jdbc:jtds:sqlserver://localhost:1433
Or with a database name:
   Database URL: jdbc:jtds:sqlserver://localhost:1433/mydbname



Any ideas? Is anyone having success connecting to SQL 2008?


Thanks,


Dave
1 comment
Comment actions Permalink

Please see the comments on
http://youtrack.jetbrains.net/issue/IDEA-56866



On 23.07.2010 18:36, Dave Merrill wrote:

(New to IDEA, sorry if I'm missing something obvious.)

>

So far I'm unable to configure a data source successfully in IDEA 902/903.

>

  Test Connection succeeds, and if I don't include a table name in the  connection string, I get the list of all tables from master. However,  providing the correct database name I get "java.sql.SQLException:  Database 'mydbname' does not exist." I've tried the latest microsoft  and jtds drivers, same behavior. This is SQL Server 2008.

>

  Not sure if it's related, but with no db name I can get the master  tables from the Data Source Properties dlg, but when I click OK and  refresh the tables from the Data Sources pane, I get "Incorrect driver  and/or connection setting specified", with the same settings that worked  in the dlg.

>
>

Also possibly related, the db name has hyphens in it. Doubt it, but do those need to be escaped somehow in the connection string?

>

  Specs I'm using for jtds are:
    JDBC Driver Class: net.sourceforge.jtds.jdbc.Driver
    Database URL: jdbc:jtds:sqlserver://localhost:1433
Or with a database name:
    Database URL: jdbc:jtds:sqlserver://localhost:1433/mydbname

>
>

Any ideas? Is anyone having success connecting to SQL 2008?

>
>

Thanks,

>
>

Dave

>
>

---
Original message URL: http://devnet.jetbrains.net/message/5268359#5268359


0

Please sign in to leave a comment.