intellij can't recognize JBoss-4.0.0

Apologize for the ancientness of the tools here, but when i try to set up a JBoss 4.0.0 app server on my linux box, it says "can't find application server libraries".

it worked fine on my windows box - i even checked the 3 files that it had used on windows to recognize the JBoss (javax.servlet.jar, javax.servlet.jsp.jar, jboss-j2ee.jar) and they are present and identical.

I first tried with Intellij 9 and got this issue - so i decided maybe 9 has forgotten about JBoss 4.0.0, so i downloaded 6.0.6 which is what i use on my windows box, and it has the same issue.

any ideas on how to resolve this?
Thanks,

Nilesh

1 comment
Comment actions Permalink

Throws this error btw:

[2386857]  ERROR -        com.fuhrer.plugin.JBoss -  
java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(ZipFile.java:114)
        at java.util.zip.ZipFile.<init>(ZipFile.java:131)
        at com.fuhrer.idea.javaee.server.JavaeeServerHelper.getLibraries(JavaeeServerHelper.java:60)
        at com.fuhrer.idea.javaee.server.JavaeeServerHelper.access$000(JavaeeServerHelper.java:17)
        at com.fuhrer.idea.javaee.server.JavaeeServerHelper$1.run(JavaeeServerHelper.java:39)
        at com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(ProgressManagerImpl.java:22)
        at com.intellij.openapi.application.impl.ApplicationImpl$1MyThread.run(ApplicationImpl.java:3)
[2386857]  ERROR -        com.fuhrer.plugin.JBoss - IntelliJ IDEA 6.0.6  Build #6197
[2386857]  ERROR -        com.fuhrer.plugin.JBoss - JDK: 1.6.0_18
[2386858]  ERROR -        com.fuhrer.plugin.JBoss - VM: Java HotSpot(TM) Server VM
[2386858]  ERROR -        com.fuhrer.plugin.JBoss - Vendor: Sun Microsystems Inc.
[2386858]  ERROR -        com.fuhrer.plugin.JBoss - OS: Linux

I can't tell what zip file it's trying to open. i of course checked all the jar files to make sure they were all valid archives...

0

Please sign in to leave a comment.