plugin development under CE on Mac hangs, dies

I'm trying to get started building a plugin.  I can't get started at all with even the basic plugin dev setup.  When I run the plugin, I was getting OutOfMemory errors; now I'm getting:

2010-03-18 13:29:06.397 java[82929:903] JavaNativeFoundation error occured obtaining Java exception description
2010-03-18 13:29:06.399 java[82929:903] Internal JNF Error: failed calling Throwable.toString()



When I start up my plugin from IntelliJ, it re-indexes my Java 6.0 installation.  When that's done, I try to open a file I've put into the otherwise-basically-empty dummy project I created to work with.  I then get a hang, and eventually an error in the output from the original IntelliJ "Run" window.  The only way I can get this to stop is by force quitting it (hence, I presume, the re-indexing on every startup).  [Technically this is not a "hang" — it does respond to basic UI requests, such as switching to the application from another, but very, very slowly, and it's using 100% of my CPU.]

I'm following the directions that say to download and build CE, which sounds good to me.  I used maven to build. (I'm using instructions on http://www.jetbrains.org/display/IJOS/Writing+Plug-ins and http://www.jetbrains.org/pages/viewpage.action?pageId=983225 )

There is a gap in the instructions between building and installing — the second step says to point my plugin SDK to my installed CE version, presumably the installed version from that build.  There is no installed dir in the results that I can see.  I did find out/artifacts/ideaIC-90.SNAPSHOT.mac.zip which I then unzipped, and I pointed my SDK at *that*.  This seemed to make the SDK generated happy.

The plugin currently is only the stub plugin.xml given on plugin creation with a trivial Action (that isn't even referenced in the plugin.xml anymore).  I don't see how that can be the issue.

Any help will be appreciated.
2 comments

http://wiki.caucho.com/Java.lang.OutOfMemoryError:_PermGen_space

I was running out of JVM permanent generation GC space.  I needed to put -XX:MaxPermSize=256m in my VM args in the configuration for running my plugin in the original IntelliJ.

I wonder if this is just me, or if anyone else is seeing this?  In any case, if the original page were a wiki, I would add a note there myself to this effect.

Wouldn't that be nice? ;-)

0
Avatar
Nicholas Tolley Cottrell

Thanks Ken. I just got

Internal JNF Error: failed calling Throwable.toString()


while testing a webapp in Tomcat and increasing the XX:MaxPermSize worked for me too!

0

Please sign in to leave a comment.