Brand new to IntelliJ, and it won't start (OS X 10.6)

I downloaded the community edition, started it, and tried to install a plugin.  I didn't restart right away, but I quit shortly afterwards.  I attempted to start it again, and it would not start.  I have logged out, restarted the computer and reinstalled intellij and still no help.

I get no window or error messages.

How do I resolve this?

Thanks,
Bill

5 comments
Comment actions Permalink

Please, remove all contents from ~/Library/Application
Suppport/IntelliJIDEA90

On 07.06.2010 1:36, bill robertson wrote:

I downloaded the community edition, started it, and tried to install a plugin.  I didn't restart right away, but I quit shortly afterwards.  I attempted to start it again, and it would not start.  I have logged out, restarted the computer and reinstalled intellij and still no help.

>

I get no window or error messages.

>

How do I resolve this?

>

Thanks,
Bill

>

---
Original message URL: http://www.jetbrains.net/devnet/message/5264835#5264835



--
Best regards,
   Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

I had that once as well, after an upgrade. It was due to a plugin
incompatibilbity.

HTH.

On 2010-06-07 09:36:46 +0800, bill robertson <no_reply@jetbrains.com> said:

I downloaded the community edition, started it, and tried to install a
plugin.  I didn't restart right away, but I quit shortly afterwards.  I
attempted to start it again, and it would not start.  I have logged
out, restarted the computer and reinstalled intellij and still no help.

I get no window or error messages.

How do I resolve this?

Thanks,
Bill

---
Original message URL: http://www.jetbrains.net/devnet/message/5264835#5264835



0
Comment actions Permalink

Hi,

Thanks for the help.  I'm afraid its still a no go.

rm -rf ~/Library/Application Support/IntelliJIdea90CE
Attempt to start, and no luck.
Reinstalled, still no luck.

Created empty dir ~/Library/Application Support/IntelliJIdea90CE
Attempt to start, still no luck.

Not sure where else to look.

Any suggestions are welcome.

thanks,
Bill

0
Comment actions Permalink

Hi,
IDEA installation has file Info.plist which
contains properties for the application, in particular:
Java | Properties | idea.config.path =
~/Library/Preferences/IntellijIdea90CE
Java | Properties | idea.system.path = ~/Library/Caches/IntellijIdea90CE
Java | Properties | idea.plugins.path = ~/Library/Application
Support/IntellijIdea90CE
Java | Properties | idea.log.path = ~/Library/Logs/IntellijIdea90CE

Please, attach idea.log file under log path, it most likely contains the
problem description you are experiencing.
Backup config directory and remove all directories (you need not create
them)

On 09.06.2010 10:12, bill robertson wrote:

Hi,

>

Thanks for the help.  I'm afraid its still a no go.

>

rm -rf ~/Library/Application Support/IntelliJIdea90CE
Attempt to start, and no luck.
Reinstalled, still no luck.

>

Created empty dir ~/Library/Application Support/IntelliJIdea90CE
Attempt to start, still no luck.

>

Not sure where else to look.

>

Any suggestions are welcome.

>

thanks,
Bill

>

---
Original message URL: http://www.jetbrains.net/devnet/message/5265057#5265057



--
Best regards,
   Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

I had the same problem after installing a plugin on Mac OS X.

In addition to the Application Support directory, IntelliJ stores settings in the following directories:

~/Library/Caches/IntelliJIdea90/
~/Library/Logs/IntelliJIdea90/
~/Library/Preferences/IntelliJIdea90/

I renamed them all and was able to restart IntelliJ.

It's too bad there is no plugin compatibility check to keep this from happening.

0

Please sign in to leave a comment.