Is this a bug?

After I installed IntelliJ IDEA 9.0.2, I tried to create a project, and then create a new class, the source code of the created class shown like the 1st attached image(intelliJ.JPG ), the comments cannot display correctlly, everything after the class definition is copied from the auto-generated comments. I tried move the cursor to the end of the first line of the class file, then pressed "Back space" two times(seems ** was deleted), you can see the result in the 2nd attached image(intelliJ2.JPG ).

I tried to create comments myself with both //, /* */ /** */, the problem still occurs.

This is the first time i use IntelliJ IDEA, the problem occurs in both community edition and evaluate ultimate edition(version 9.0.2).
What is the problem? is that I need to setup something before using IntelliJ IDEA?

My desktop info:

OS: Windows XP(Chinese)
JDK version: "1.6.0_13"
System default encoding: Big5

1 comment
Comment actions Permalink

Looks like an encoding issue. You mention your default system encoding is Big5 and the I see the file has an encoding of x-windows-950 as shown in the lower right of the status bar.

Check the IDEA File Encoding setting for the IDE. Settings > Project Settings > File Encodings > IDE Encoding. That may be set incorrectly. You may also need to change the encoding of the file by clicking on encoding shown in the lower right of the status bar.  If changing the IDE encoding resolves your issue, you may want to change it in the Template Settings: File > Other Settings > Template Settings > Project Settings > File Encodings > IDE Encoding.


Please sign in to leave a comment.