1071 - <jsp:setProperty> not working?

Hello!

In my jsp page, i have the following code:

]]>


The bold 'sbDatabase' setProperty name is marked as an error, saying 'cannot resolve symbol sbDatabase'.

This worked fine in builds prior to 1071. Is this a bug, or do I missed something?

Thanks in advance,

Robin

3 comments
Comment actions Permalink

Robin van het Hof wrote:

Hello!

In my jsp page, i have the following code:

> ]]>


The bold 'sbDatabase' setProperty name is marked as an error, saying 'cannot resolve symbol sbDatabase'.

This worked fine in builds prior to 1071. Is this a bug, or do I missed something?

Yes.. This is a bug. It is fixed in 1074.

IK

--
Igor Kuralenok
Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Cool, thanks!
Now I can go home :)

0
Comment actions Permalink

Hello,

In my jsp page, the following code appears but all the java references to 'trafficLightPersonalisation' and 'AASRepository' error due to 'Cannot resolve symbol'. The project is set up as a Java module type.

A portion of the code follows:

&lt;%@ taglib uri="bloxtld" prefix="blox" %&gt;
&lt;%@ taglib uri="bloxuitld" prefix="bloxui" %&gt;
&lt;%@ taglib uri='bloxformtld' prefix='bloxform' %&gt;

&lt;blox:repository id="AASRepository" /&gt;

&lt;jsp:useBean id="trafficLightPersonalisation" scope="session"&gt;
&lt;%
// The reference to trafficLightPersonalisation has a cannot resolve symbol error
trafficLightPersonalisation.init(AASRepository);
%&gt;
&lt;/jsp:useBean&gt;

&lt;%
// The reference to AASRepository has a cannot resolve symbol error
String jcCustomer = AASRepository.getUserProperty("jcCustomer") ;

0

Please sign in to leave a comment.