Intellij and Pipe character on OSX

Hello

I am new on IntelliJ and I am currently testing the version 9.0.2 on Mac OSX Snow Leopard with a French keyboard.
I am not able to enter pipe characters through the keyboard combination (alt shift L). This combination is linked to a keymap defined on intellij.
Is there a way to workaround this behavour to let me enter pipe characters?

Thanks for your help

1 comment
Comment actions Permalink

Hi,

I have found how to use the pipe character on OSX with IntelliJ 9.0.2.

I have perform the following operation:

  • Open "File > Settings"
  • Select "IDE Settings > Keymap"
  • Select your Keymap (ex: "Mac OS X") and click on “Copy”
  • Label your custom Keymap (ex: My OS X Keymap)
  • Click on Apply and stay in the Keymap settings
  • Select the KeyMap that "disturb" the pipe character located under: "Main Menu > Tools > Context > Load .."
  • From the Shortcuts area, remove this shortcuts
  • Click on Apply and then OK
  • Back to your editor, type Alt+Shift+L to print-out the pipe character.

I hope this help.
0

Please sign in to leave a comment.