Can't svn add.

I installed IntelliJ9 a few days ago to evaluate an upgrade from 8.  I can't seem to svn add.  I get hit and miss results on the dialogue that appears post-file creation that also asks if you want it added to the svn repository.  But, if I visit the menu at Version Control > Subversion, the Add option is always grayed out.  Also interestingly, I get no Subversion option in the context menu when I right-click on the file in the project view or in the main code view window.  When I run "svn st" on the commandline in my project directory, svn indeed does not know about these files (not added).  I'm on Ubuntu 9.10 and have installed twice trying to get around this.  I deleted the ~/.IntelliJIdea90 directory before the second install and made sure to not disable any plugins on the second try.

Has anyone else seen this behavior?

6 comments
Comment actions Permalink

check if your project (root) is added to version control

project settings > version control

0
Comment actions Permalink

Wow, that was it.  Chalk that up to user blunder, I guess.  With the same project, I never had to do that in version 8.  Great suggestion.  Thank you!

0
Comment actions Permalink

It wasn't your fault ;-)
Idea is not detecting version control  properly (I think they've fixed this issue within last EAP, but I am not sure)

0
Comment actions Permalink

On some occasions, users just forgot to set the project settings for version control.

i.e. silently adding into the subversion or asks the user for add or not, or do not add at all in the Project SEttings

0
Comment actions Permalink

Hello J,

Please check the VCS configuration in Settings | Version Control and ensure
that the entirety of your project is marked as under VCS.

I installed IntelliJ9 a few days ago to evaluate an upgrade from 8.  I
can't seem to svn add.  I get hit and miss results on the dialogue
that appears post-file creation that also asks if you want it added to
the svn repository.  But, if I visit the menu at Version Control >
Subversion, the Add option is always grayed out.  Also interestingly,
I get no Subversion option in the context menu when I right-click on
the file in the project view or in the main code view window.  When I
run "svn st" on the commandline in my project directory, svn indeed
does not know about these files (not added).  I'm on Ubuntu 9.10 and
have installed twice trying to get around this.  I deleted the
~/.IntelliJIdea90 directory before the second install and made sure to
not disable any plugins on the second try.

Has anyone else seen this behavior?

---
Original message URL:
http://www.jetbrains.net/devnet/message/5253800#5253800

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I had the a similar issue and was not able to get a new folder added to svn. Like most of the issues with IDEA, a restart of idea helped fixed it.

0

Please sign in to leave a comment.