"Open Recent" doesn't work

Here's a weird one.  For some time now I've been experiencing a problem where IntelliJ 9.0.1 opens to a grey background and the 'Open Recent' menu option won't open a project.  It allows you to pick one but doesn't do anything once you have.  You can use the open menu option to navigate to a project and then open it and all works correctly after that.  I just upgraded to 9.0.2 today and on the first start I got the welcome screen in IntelliJ and the 'Open Recent' option worked.  On the next startup I got a grey background and the 'Open Recent' was broken again.

What can I do to track this problem down and resolve it?

I'm on OS/X 10.6.3.  I don't remember when I started seeing the problem initially but its possible it was in the save period that I upgraded from 10.6.2 to 10.6.3.  Since I initially noticed the problem I've purchased a new machine and installed IntelliJ on that machine.  The problem is still being exhibited.

5 comments

Hello Charles,

Are there any exceptions in ~/Library/Logs/IntelliJIdea90/idea.log ?

Here's a weird one.  For some time now I've been experiencing a
problem where IntelliJ 9.0.1 opens to a grey background and the 'Open
Recent' menu option won't open a project.  It allows you to pick one
but doesn't do anything once you have.  You can use the open menu
option to navigate to a project and then open it and all works
correctly after that.  I just upgraded to 9.0.2 today and on the first
start I got the welcome screen in IntelliJ and the 'Open Recent'
option worked.  On the next startup I got a grey background and the
'Open Recent' was broken again.

What can I do to track this problem down and resolve it?

I'm on OS/X 10.6.3.  I don't remember when I started seeing the
problem initially but its possible it was in the save period that I
upgraded from 10.6.2 to 10.6.3.  Since I initially noticed the problem
I've purchased a new machine and installed IntelliJ on that machine.
The problem is still being exhibited.

---
Original message URL:
http://www.jetbrains.net/devnet/message/5261451#5261451

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Yes.  I solved the problem.  It appears that IntelliJ doesn't like projects to be located past a soft link.  I saw the exception in the log and switched to the "normal" path for the project and the problem resolved itself.  I don't need any further assistance with this - I just need to remember not to load projects through links.

Here's the exception for future reference:

2010-04-22 10:57:22,879 [   4807]  ERROR - plication.impl.ApplicationImpl - null
java.lang.AssertionError
 at com.intellij.openapi.components.impl.stores.ProjectStoreImpl.getProjectName(ProjectStoreImpl.java:274)
 at com.intellij.openapi.project.impl.ProjectImpl.<init>(ProjectImpl.java:104)
 at com.intellij.openapi.project.impl.ProjectManagerImpl.a(ProjectManagerImpl.java:243)
 at com.intellij.openapi.project.impl.ProjectManagerImpl.a(ProjectManagerImpl.java:293)
 at com.intellij.openapi.project.impl.ProjectManagerImpl.access$200(ProjectManagerImpl.java:72)
 at com.intellij.openapi.project.impl.ProjectManagerImpl$6.run(ProjectManagerImpl.java:455)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl$3.run(ProgressManagerImpl.java:245)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl$TaskRunnable.run(ProgressManagerImpl.java:428)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl$4.run(ProgressManagerImpl.java:256)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl$2.run(ProgressManagerImpl.java:198)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:223)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(ProgressManagerImpl.java:189)
 at com.intellij.openapi.application.impl.ApplicationImpl$6$1.run(ApplicationImpl.java:490)
 at com.intellij.openapi.application.impl.ApplicationImpl$5.run(ApplicationImpl.java:329)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
 at java.lang.Thread.run(Thread.java:637)
 at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:125)

0

I have been having the same problem on my work PC but that's running Win32
with no links of any kind. If I close the current project then open the other
project everything is OK, but if I try to use Open or Open Recent while an
existing project is open, nothing happens (though I assume there's an error
in the log file).

Note that this was happening pretty consistently on at least the two most
recent EAP builds. I just installed the release 2.0.2 build today but didn't
test for this problem so maybe it's already fixed in that build... I'll check
when I get in the office tomorrow.

Chris

Yes.  I solved the problem.  It appears that IntelliJ doesn't like
projects to be located past a soft link.  I saw the exception in the
log and switched to the "normal" path for the project and the problem
resolved itself.  I don't need any further assistance with this - I
just need to remember not to load projects through links.

Here's the exception for future reference:

2010-04-22 10:57:22,879   ERROR -
plication.impl.ApplicationImpl - null
java.lang.AssertionError
at
com.intellij.openapi.components.impl.stores.ProjectStoreImpl.getProjec
tName(ProjectStoreImpl.java:274)
at
com.intellij.openapi.project.impl.ProjectImpl.<init>(ProjectImpl.java:
104)
at
com.intellij.openapi.project.impl.ProjectManagerImpl.a(ProjectManagerI
mpl.java:243)
at
com.intellij.openapi.project.impl.ProjectManagerImpl.a(ProjectManagerI
mpl.java:293)
at
com.intellij.openapi.project.impl.ProjectManagerImpl.access$200(Projec
tManagerImpl.java:72)
at
com.intellij.openapi.project.impl.ProjectManagerImpl$6.run(ProjectMana
gerImpl.java:455)
at
com.intellij.openapi.progress.impl.ProgressManagerImpl$3.run(ProgressM
anagerImpl.java:245)
at
com.intellij.openapi.progress.impl.ProgressManagerImpl$TaskRunnable.ru
n(ProgressManagerImpl.java:428)
at
com.intellij.openapi.progress.impl.ProgressManagerImpl$4.run(ProgressM
anagerImpl.java:256)
at
com.intellij.openapi.progress.impl.ProgressManagerImpl$2.run(ProgressM
anagerImpl.java:198)
at
com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessU
nderProgress(ProgressManagerImpl.java:223)
at
com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(Prog
ressManagerImpl.java:189)
at
com.intellij.openapi.application.impl.ApplicationImpl$6$1.run(Applicat
ionImpl.java:490)
at
com.intellij.openapi.application.impl.ApplicationImpl$5.run(Applicatio
nImpl.java:329)
at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441
)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecu
tor.java:886)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.
java:908)
at java.lang.Thread.run(Thread.java:637)
at
com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(Applicat
ionImpl.java:125)
---
Original message URL:
http://www.jetbrains.net/devnet/message/5261528#5261528



0

Hmm good news, it appears to be fine for me now in 9.0.2. I guess the bug
must have been fixed.

I have been having the same problem on my work PC but that's running
Win32 with no links of any kind. If I close the current project then
open the other project everything is OK, but if I try to use Open or
Open Recent while an existing project is open, nothing happens (though
I assume there's an error in the log file).

Note that this was happening pretty consistently on at least the two
most recent EAP builds. I just installed the release 2.0.2 build today
but didn't test for this problem so maybe it's already fixed in that
build... I'll check when I get in the office tomorrow.

Chris



0

Hopefully there comes fix for this. Because it's little bit pain in you know where.

I just used whole day to figure out why last project or recent projects didn't work at all.

0

Please sign in to leave a comment.