Problem deploying webapp in Tomcat from Maven project

Hi all,

My girlfriend is working in a company currently with Eclipse. She's keen to move to IDEA, so we've been trying to deploy her project in IDEA at home. However it fails to deploy with a strange problem - it can't find classes for SLF4J. These classes come from the SLF4J implementation jars which are set as a runtime dependency in her web app pom. This deploys fine in Eclipse, and we've also built the war from the Maven project and it works fine too.

I've worked with IDEA for many years now but I've never done web development or worked with Maven, so I'm not sure where to start looking. Any help would be appreciated. We've seen 3 main problems:

1. The aforementioned java.lang.ClassNotFoundException: org.slf4j.impl.StaticLoggerBinder. We can't even find where the Tomcat plugin is deploying the app to make sure it's deploying the jars correctly.

2. We noticed that the two modules using SLF4J previously appeared marked with errors in the Maven Projects view and that the message was that it was missing two dependencies, which were precisely the two SLF4J jars. I think Maven had downloaded the poms but not the jars, but now the jars are there and the Maven Projects window is clean.

3. Unrelated to this problem, whenever we start the project we get a background task "Discovering location for <module>" for one of the modules. This module comes from an SVN repo that I don't have access to here at home - could that be the problem? If so, can I stop this behaviour?

Thanks for any and all help. Since I've not worked with this combination before this is kind of a black box for me.


1 comment
Comment actions Permalink

Actually, don't mind me. This has mysteriously started working.



Please sign in to leave a comment.