FlexUnit runner runs Flash CS3 instead of Debug Player

On the Mac, how does idea launch the debug player for running FlexUnits?  On my machine it runs Flash CS3 instead of the debug, standalone Flash Player I have installed. CS3 seems to want to control the debugger itself, so the flex unit tests never complete.

If I symlink the Flash Player binary over top of where the CS3 binary lives, then everything works.

My default application for .swf is Flash Player; in other words, if I double click on a .swf in the finder, it opens Flash Player.

So, how does idea launch the player?

Thanks,

-c

Idea: 9.0.2
Macos: 10.6.3
Flash Player: 10,0,45,2

1 comment

If you have 'Use system default browser' selected at Settings | Web Browsers then IDEA launches FlexUnit run configuration in the same way as it launches swf or html wrapper or URL for Flex run configuration: it executes OS command
open file:/<absolute swf or html file path>
or
open <URL>

So you need to check your OS settings. May be the latest launched Flash Player or CS3 makes itself default application for swf. So just manually launch and close Flash Player and then launch FlexUnit from IDEA.

0

Please sign in to leave a comment.