JSTL / EL not rendering

I just migrated my existing mavenized web application from Eclipse to Intellij. When I run the web application in either Tomcat or Jetty (launched in Intellij), it doesn't render all my EL's curly braces.

It works fine when I launched the app in Eclipse, so I think I'm missing some configurations in Intellij here.

I do have jstl.jar included in my pom.xml.

Help? Thanks much.

2 comments

Here's a little more specific... I just created a test web project.

This is my simplified pom.xml file:-

=============
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
    <modelVersion>4.0.0</modelVersion>
    <groupId>testweb</groupId>
    <artifactId>testweb</artifactId>
    <packaging>war</packaging>
    <version>1.0</version>
    <name>testweb Maven Webapp</name>
    <url>http://maven.apache.org</url>

    <build>
        <finalName>testweb</finalName>

        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <configuration>
                    <source>1.6</source>
                    <target>1.6</target>
                </configuration>
            </plugin>
            <plugin>
                <groupId>org.mortbay.jetty</groupId>
                <artifactId>maven-jetty-plugin</artifactId>
            </plugin>
        </plugins>
    </build>


    <dependencies>
        <dependency>
            <groupId>javax.servlet</groupId>
            <artifactId>jstl</artifactId>
            <version>1.2</version>
        </dependency>
    </dependencies>

</project>
=============

I have this line in the index.jsp:-
=============
## ${pageContext.request.requestURI} ##
=============

When I run mvn jetty:run, that EL doesn't get rendered.

What am I doing wrong here? Thanks.

0

web.xml version should be 2.4 or higher.

0

Please sign in to leave a comment.