2126: Weirdest behavior

I am using build 2126 and I am currently experiencing the weirdest thing I have ever come across in IDEA.

I had been editing an xml file for some time when I noticed a few strange things about it, e.g. the editor was behaving as if the "Allow placement of caret after end of line" option was turned on (which it ain't). Interestingly, all other editors were behaving correctly.

I then went on to make a test case out of it and tried to copy the content of a different xml file into the weird file, and doing that, all tags came out in reverse order!

I tried it with different data, and the behavior was the same: I copied the block



from an external file to the clipboard and pasted it into the "sick" file, and the result was


in one line, without line feeds (but with xml syntax violations correctly highlighted).

Has anyone ever seen anything like that? I am hesitant to shut down the IDE or even close the file because the bug might disappear and not be reproducible; on the other hand, I wouldn't know how to get additional information that might be useful for JB out of the application.


1 comment
Comment actions Permalink

Alright, I did find the cause of the strange behavior: I just found out that I had Column Mode turned on for that particular file.

Yet I don't think that the editor should behave that way!



Please sign in to leave a comment.