-Xms not working in 9.0.2.

I set the value to -Xms512m and the application shows 82m of 127m on the status line. This happened after I updated to the latest version

10 comments
Comment actions Permalink

Where did you set this? In <IDEA_9.0.2_PATH>/bin/idea.exe.vmoptions ?

0
Comment actions Permalink

Correct, the file contains...

-Xms512m
-Xmx1g
-XX:MaxPermSize=250m
-ea
-server





BTW, the -server option does not appear to be working but that has been broken for awhile.
0
Comment actions Permalink

How do you run Idea? What's your OS?

I believe this is still valid information http://blogs.jetbrains.com/idea/2006/04/configuring-intellij-idea-vm-options/

0
Comment actions Permalink

This might happen if you use the vmoptions plugin. Just restart and all is back to normal...

Regards,
Wallaby

0
Comment actions Permalink

I start Idea from the Idea.exe file in the bin directory. I am running Window 7 64 bit.

I have not had a problem until I upgraded to 9.0.2

0
Comment actions Permalink

I am not using that plugin.

0
Comment actions Permalink

Where are you getting your numbers from ?
Is this version of IJ acting differently from previous version of IJ ? I don't see a change in this version of IJ.

The memory usage icon in the lower right hand gutter of IJ has allways displayed how much total heap or maybe heap+perm space is used not how much is allocated.
Windows task manager to me also appears to report how much is used, even though java on windows reserves the max memory on startup.

-Rob

0
Comment actions Permalink

Make sure UAC is not playing tricks on you. Java doesn't seem to see the virtualized files that windows uses if an application tries to write to c:\program files. You could try to run a text editor with administrator priviledges and edit the idea.exe.vmoptions file with that editor. The problem is UAC related if that solves your problem.

Please see also here: http://youtrack.jetbrains.net/issue/IDEA-27241

0
Comment actions Permalink

That seems to have worked. I set the UAC to 'allow everything' and it now works.

0
Comment actions Permalink

I don't think the -server option is used unless you start it up via the .bat file on Windows.

0

Please sign in to leave a comment.