Using 1.5 compiler to target 1.4

Is it possible to use Java 1.5 in 4.1 but still be 1.4 compatible? I
would like to be able to use the new language features, but not the new
api that is not compatible with 1.4.
I'm not sure how this could be implemented, but I can see this as
something that others would possibly want. We interoperate with other
products and customers that are tied to 1.4, but since the language
features are supposed to produce 1.4 compatible byte codes, things
should still work.

adam

2 comments
Comment actions Permalink

The 1.5 features do not produce 1.4-compatible bytecode. You might want to look into RetroWeaver at http://retroweaver.sourceforge.net/ though.

0

Please sign in to leave a comment.