Build 2091 - Console window on Win2K

All properties below are set to empty but console window is coming up, is there any way to get rid of it?

lax.stderr.redirect=
lax.stdin.redirect=
lax.stdout.redirect=

8 comments
Comment actions Permalink

Since you are using an eap version it is assumed you will be reporting
bugs/exceptions and therefore should have the console window open.

Vladimir Goncharov wrote:

All properties below are set to empty but console window is coming up, is there any way to get rid of it?

lax.stderr.redirect=
lax.stdin.redirect=
lax.stdout.redirect=

0
Comment actions Permalink

Why is it so, what about automatic error reporting that we have been using for the last 12 month?

0
Comment actions Permalink

The exceptions popup in windows anyway. If it's something critical, all we know how to find and read the logs, right ?! I don't see a reason to bloat my desktop with the console. Someone knows how to hide it ?

0
Comment actions Permalink

You can copy idea.exe from previous build (2079). Works for me (Win2K).

0
Comment actions Permalink

JetBrains, is that an official decision or is this a bug we should report?

"Vladimir Goncharov" <vladimir.goncharov@citigroup.com> wrote in message
news:19686552.1086632689593.JavaMail.itn@is.intellij.net...

All properties below are set to empty but console window is coming up, is

there any way to get rid of it?
>

lax.stderr.redirect=
lax.stdin.redirect=
lax.stdout.redirect=



0
Comment actions Permalink

Any news on this? The console window is quite annoying.

-Jason

0
Comment actions Permalink

You can use this batch file until this problem's sorted. Run it from
your idea bin directory.

Cheers,
N.

Jason Boehle wrote:

Any news on this? The console window is quite annoying.

-Jason

@echo off

::----


:: IntelliJ IDEA Startup Script
::----



::----


:: Uncomment the following 2 lines if you are going to
:: associate "*.ipr" files with IntelliJ IDEA
::----


:: cd C:\IntelliJ-IDEA-3.0\bin\
:: C:

:: -


:: Before you run IntelliJ IDEA specify the location of the
:: directory where IntelliJ IDEA is installed
:: In most cases you do not need to change the settings below.
:: -


SET IDEA_HOME=..

:: -


:: In most cases you do not need to change the settings below.
:: -


SET JAVA_EXE=%IDEA_HOME%\jre\bin\javaw.exe

IF NOT EXIST "%JAVA_EXE%" goto error

SET MAIN_CLASS_NAME=com.intellij.idea.Main

:: -


:: There are two possible values of IDEA_POPUP_WEIGHT property: "heavy" and "medium".
:: If you have WM configured as "Focus follows mouse with Auto Raise" then you have to
:: set this property to "medium". It prevents problems with popup menus on some
:: configurations.
:: -


SET IDEA_POPUP_WEIGHT=heavy

:: -


:: You may specify your own JVM arguments in IDEA_JVM_ARGS variable.
:: -


IF "%IDEA_JVM_ARGS%" == "" set IDEA_JVM_ARGS=-Xms32m -Xmx192m -Dsun.java2d.noddraw=true

IF "%IDEA_CONFIG_PATH%" == "" set IDEA_CONFIG_PATH=~/.IntelliJIdea/config
IF "%IDEA_SYSTEM_PATH%" == "" set IDEA_SYSTEM_PATH=~/.IntelliJIdea/system
IF "%IDEA_PLUGINS_PATH%" == "" set IDEA_PLUGINS_PATH=%IDEA_HOME%/plugins

SET JVM_ARGS= %IDEA_JVM_ARGS% -Didea.plugins.path=%IDEA_PLUGINS_PATH% -Didea.system.path=%IDEA_SYSTEM_PATH% -Didea.config.path=%IDEA_CONFIG_PATH% -Didea.popup.weight=%IDEA_POPUP_WEIGHT%

SET OLD_PATH=%PATH%
SET PATH=%IDEA_HOME%\bin;%PATH%

SET CLASS_PATH=%IDEA_HOME%\lib\idea.jar
SET CLASS_PATH=%CLASS_PATH%;%IDEA_HOME%\lib\jdom.jar
SET CLASS_PATH=%CLASS_PATH%;%IDEA_HOME%\lib\openapi.jar
SET CLASS_PATH=%CLASS_PATH%;%IDEA_HOME%\lib\log4j.jar

:: -


:: You may specify additional class paths in IDEA_CLASS_PATH variable.
:: It is a good idea to specify paths to your plugins in this variable.
:: -


IF NOT "%IDEA_CLASS_PATH%" == "" SET CLASS_PATH=%CLASS_PATH%;%IDEA_CLASS_PATH%

start %JAVA_EXE% %JVM_ARGS% -cp "%CLASS_PATH%" %MAIN_CLASS_NAME% %*

SET PATH=%OLD_PATH%
goto end
:error
echo -


echo ERROR: cannot start IntelliJ IDEA.
echo No JRE found in IDEA installation directory
echo -


pause
:end

0

Please sign in to leave a comment.