Why IDEA resorts javadoc tags on format?

/**

  • Sets OrgUnitTypeImpl.folder

  • <br/>

  • This value is required and can not be null

  • @dbgen:generated

  • @dbgen:generated-javadocs

  • @param folder OrgUnitTypeImpl folder

*/


after formating I get

/**

  • Sets OrgUnitTypeImpl.folder

  • <br/>

  • This value is required and can not be null

*

  • @param folder OrgUnitTypeImpl folder

  • @dbgen:generated

  • @dbgen:generated-javadocs

*/


my custom tags got pushed to the bottom.

Is there any way to avoid resorting the tags?


1 comment
Comment actions Permalink


I think that the only way to do what you want is to disable javadoc formatting. Go to Settings -> (Global/Project) Code Style -> Javadoc and uncheck the "Enable Javadoc Formatting" box.

0

Please sign in to leave a comment.