Auto-update to EAP

I see that you have implemented one-click updating of IDEA to newer version. But it does not update to latest EAP automatically (I have to download its redistributable manually). Why?

7 comments

Hello Evgeny,

I see that you have implemented one-click updating of IDEA to newer
version. But it does not update to latest EAP automatically (I have to
download its redistributable manually). Why?


We only provide patches between directly adjacent builds (from EAP to next
one and from bugfix to next one). Building all combinations of patches between
different builds is not feasible for us at the moment.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

One problem I've noticed is that even when I'm only moving up one EAP version,
IDEA offers to download and install the patch but still doesn't apply it.
The download appears to take place and IDEA then restarts, but comes up as
the old version still and asks me if I want to upgrade to the new version
again...

Has anyone else seen this? It's been happening for quite a few builds now.
I honestly can't remember the last time I had the auto-update work, it always
seems to fail for one reason or another and result in me needing to manually
update.

Chris

Hello Evgeny,

>> I see that you have implemented one-click updating of IDEA to newer
>> version. But it does not update to latest EAP automatically (I have
>> to download its redistributable manually). Why?
>>

We only provide patches between directly adjacent builds (from EAP to
next one and from bugfix to next one). Building all combinations of
patches between different builds is not feasible for us at the moment.



0

In Windows 7/Vista you'll need to run IDEA as administrator for the update to work (dunno why though).

0

We only provide patches between directly adjacent builds (from EAP to next

one and from bugfix to next one). Building all combinations of patches between
different builds is not feasible for us at the moment.

For the upgrade from 94.633 to 95.4 I just get the "More Info..." dialog.
I thought these were directly adjacent builds. Is this to be expected?

In Windows 7/Vista you'll need to run IDEA as administrator for the
update to work (dunno why though).


Interesting, I hadn't thought of that! I'll give it a try next time I'm offered
an upgrade. Of course it goes without saying that it would be nice if running
as admin wasn't required (but the usual prompt for admin rights was presented
during the upgrade if need be).

Chris


0

Hello Chris,

For the upgrade from 94.633 to 95.4 I just get the "More Info..."
dialog. I thought these were directly adjacent builds. Is this to be
expected?


Yes, unfortunately in this case we're not providing a patch.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

OK thanks Dmitry, that's good to know. It sounds like the problems I'm seeing
just boil down to the lack of my running IDEA as administrator when trying
to apply a patch then.

Cheers,
Chris

Hello Chris,

>> For the upgrade from 94.633 to 95.4 I just get the "More Info..."
>> dialog. I thought these were directly adjacent builds. Is this to be
>> expected?
>>

Yes, unfortunately in this case we're not providing a patch.



0

Please sign in to leave a comment.