Make shows compile errors where there are no errors

Hi,

I just started with IntelliJ, so this might be a stupid question.
I want to run some unit tests but the previously performed compiling (or "Make"), shows errors: "cannot find symbol method foo()". But, this method exists. Other methods in this class work fine (no errors shown), even code completion is working for these methods. The strange thing was, that it worked before. After I have done some refactoring (in completely other parts of my app, I did not touch any class that is in the error list now) this weird behaviour occurs.

What could be my mistake here. Do I need to set some settings or to check something? Is there something like "Cleanup Project" like in Eclipse?

Thanks in advance,
Markus

2 comments

Did you try to invoke Build | Rebuild Project action?

Hi,

I just started with IntelliJ, so this might be a stupid question.
I want to run some unit tests but the previously performed compiling (or "Make"), shows errors: "cannot find symbol method foo()". But, this method exists. Other methods in this class work fine (no errors shown), even code completion is working for these methods. The strange thing was, that it worked before. After I have done some refactoring (in completely other parts of my app, I did not touch any class that is in the error list now) this weird behaviour occurs.

What could be my mistake here. Do I need to set some settings or to check something? Is there something like "Cleanup Project" like in Eclipse?

Thanks in advance,
Markus

---
Original message URL: http://www.jetbrains.net/devnet/message/5259713#5259713



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Thanks Nikolay,

I don't get it, but after a Rebuild, it works. This is pretty weird. (I even quit Intellij and restarted it, without any effect). But anyway, now I can run my testcases again and I am happy.

Cheers,
Markus

0

Please sign in to leave a comment.