How to re-enable 'create unit test' intention?

I accidentally disabled my 'create unit test' intention on a class name, and I can't seem to find anywhere to re-enable it.  It doesn't even seem to be listed under the intentions preferences, and I can't seem to find any configs that list out what intentions are set to.

To be clear, this is the intention when you put your cursor on a class name and hit alt-enter  (it's grouped with 'create subclass').  This is incredibly annoying.

I'm on osx with idea9.

Thanks,
  Mat

2 comments

I've hit the same problem and searched everywhere in the IDEA 9.0.1 community edition UI.

In the end I decided to search the config files directly and found the following in ${idea_config_dir}\.IntelliJIdea90\config\options\intentionSettings.xml

<?xml version="1.0" encoding="UTF-8"?>
<application>
  <component name="IntentionManagerSettings">
    <ignoreAction name="Create Test" />
  </component>
</application>

changing this to

<?xml version="1.0" encoding="UTF-8"?>
<application>
  <component name="IntentionManagerSettings">
  </component>
</application>

fixed the problem.

Cheers,
Parwy

0

Thank you very much.
As a workaround, if you use the 'switch to unit test' command, it will bring up the same dialog for creating the unit test if one doesn't exist.

Mat

0

Please sign in to leave a comment.