intellij webspere 7 integration questions

Hello Friends:

I am trying to configure Intellij Idea 9.0  to deploy ear (which contains only war) to Websphere 7.

I built archived ear (boy that was something).

Should I do the first deployment to Websphere from the admin console ?

After the first deploy will IntelliJ manage further deployments ?

Should I do deployments from outside using ant/maven ?  on a continious basis ?

For debugging should I set any server side settings so the debug occurs right ?

Please help and share your experience.

-Narahari

4 comments
Comment actions Permalink

No taker I assume.

May be I dont know how development is to be done with IntelliJ is done in the normal  J2EE direction or the product has a different paradigm I need to learn.

I come from RAD (Rational Application Developer) side of things where the plugins of RAD (on top of eclipse) make it relatively easier to connect and debug on Websphere.

I was expecting that IntelliJ after configuring say an EAR file archived approach will create the app.ear in say the out folder.  This happened.

Should I deploy the ear that got created the first time by myself into Websphere thru admin console ?

What about successive builds ?  Does IntelliJ publish the ear files to Websphere automagically ?

-Narahari

0
Comment actions Permalink

If you've configured structure of ear in IDEA (in Project Structure dialog | Artifacts) you'll be able to deploy/redeploy your application to
WebSphere from IDEA (create WebSphere run configuration in Run | Edit configurations dialog). However if your ear is build by ant you need to use ant
or the admin console to deploy the application.

Hello Friends:

I am trying to configure Intellij Idea 9.0  to deploy ear (which contains only war) to Websphere 7.

I built archived ear (boy that was something).

Should I do the first deployment to Websphere from the admin console ?

After the first deploy will IntelliJ manage further deployments ?

Should I do deployments from outside using ant/maven ?  on a continious basis ?

For debugging should I set any server side settings so the debug occurs right ?

Please help and share your experience.

-Narahari

---
Original message URL: http://www.jetbrains.net/devnet/message/5257938#5257938



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Thanks for the answer.  I think that Idea9 part of deploy is not working out with Websphere 7.

I have a simple servlet that I am trying to the deployment stuff.  I have attached that here.

Any one can comment on what I am doing wrong would be appreciated.

-Narahari



Attachment(s):
Testing.jar
0
Comment actions Permalink

Please download the latest IDEA 7.0.2 EAP build from http://confluence.jetbrains.net/display/IDEADEV/Maia+EAP. It contains some fixes related to
deployment to WebSphere 7.

Thanks for the answer.  I think that Idea9 part of deploy is not working out with Websphere 7.

I have a simple servlet that I am trying to the deployment stuff.  I have attached that here.

Any one can comment on what I am doing wrong would be appreciated.

-Narahari

---
Original message URL: http://www.jetbrains.net/devnet/message/5258157#5258157



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.