Deploying webapp into Websphere

Anyone working with Websphere 6.1? Please help me out...

I have a webapp that I need to be able to deploy into WAS 6.1 from IntelliJ. At first, I used the WAS Admin Tool to deploy that WAR, and everything worked fine. When I later created a JEE module in IntelliJ and deployed it as an EAR file, it also worked sort of ok, for a while - although the server had spewed some exceptions during startup, the application still came up and ran fine. Note that I had previously setup the app under WAS using the IBM's admin tool. Then, I tried to deploy the same app on a machine with a fresh installation of WAS 6.1 directly from IntelliJ - without first installing it via the admin console. So, I had the "application.xml" file in my META-INF folder, I created a JEE facet, specified deployment as an EAR, etc. When I try to launch the server, WAS complains that it is not finding the "deployment.xml" file for the application. I thought that Websphere would create that file automatically. Is that not true? I suppose that the reason the app deployed from IntelliJ ok before was because that file was already created by WAS when I originally installed the app using the Admin tool. Could someone please give me a hint about what's going on? I don't have to manually create "deployment.xml" and add it to the list of the custom server descriptors, do I? It seems that when WAS creates it, it auto-generates various IDs. Is it ok to just make them up if I manually create this file? I don't see anything else in IntelliJ that I may have missed when creating the WAS/JEE facet configurations...

(Needless to say, I haven't used Websphere with IntelliJ before, so I apologize if the question is stupid.)


Thanks for any suggestions.

2 comments

OK, it looks like the server error messages I was seeing refered to the old deployment configurations that I ran in the past (named differently) and that don't exist any more. I must have not properly un-installed them, just manually deleted the subfolders in the DeployedApplications directory and config. Apparently, Websphere keeps a ton of other info elsewhere that makes it think the apps are still installed, and attempts to load them again each time it starts, can't find the "deployment.xml" files for them and pukes all over. Finally, if I wait long enough (and, hell, it takes time!) it does get to my latest configuration and loads it ok. So, it looks like, once I have launched the WAS deployment from IntelliJ, even if it fails for whatever reason, I would have to properly uninstall it, perhaps by using the server admin tool. Thanks for all the overwhelming feedback this post has provoked!!! :)))))))))

0

Hello Sir:

Did this issue get resolved for you ?  I am kinda in a same situation.

-Narahari

0

Please sign in to leave a comment.