Auto-Import Weirdness

Arrgggg. I love IDEA, but version 9 has been outright flaky, flaky, flaky for me. From bizarre maven behavior to inconsistent performance (on a super high end machine) and now an oddity with imports.

Ok, so I'm typing in a class or annotation like so:

@Service

Right after I type the last "e" in "Service", IDEA used to popup a message asking if I wanted to import the class. Now it doesn't. I have to actually move my cursor away from the class before IDEA will ask if I want to import it. Why? I know this seems minor, but it doesn't make sense from a workflow perspective. Once I move away from the class definition, I'm on to some other thought and then, WHAM! I get the import request. When it popped up right after typing the class it was entirely appropriate.It's nto a timing thing either. I can leave my cursor there at the end of the class for minutes and still no popup.

There are about half  dozen of these little changes in IDEA 9 that I've run across in just the few days I've been running it and they just don't seem to make any sense.

3 comments
Comment actions Permalink

I have seen that, too.
Once you move the caret is starts to popup the import popups.

And if you enable the option to auto import classes which don't have to names matching then it only imports the classes currently visible on the screen, you have to move to the other currently invisible areas to import the classes there.

I think / hope that this is  a bug. I someone from Jetbrains confirms you could open a Youtrack issue, I think.

Wallaby

0
Comment actions Permalink

Here's another import quirk that's driving me nuts. Even when the auto-import popup does come up, it now behaves in an absolutely maddening manner. All of the possible choices for importing have a little arrow on their right which leads to more choices. For some reason, more than half the time when I hit alt-enter to bring up my import choices, the selection cursor behaves as if I had selected that arrow and moves the current selection to that next level menu instead of the main one.

Seriously, how could such an easy, intuitive behaviour as this auto-import process used to be have gone so wrong? What happened to "Develop with pleasure?"

0
Comment actions Permalink

I'm sure I sound like a bitter, crochety complainer, but when I pay out of pocket for an IDE in a market where free ones proliferate, I feel a little justified in complaining when it doesn't perform as expected.

Here's another way 9 takes a step backwards from 8. In 8, when I added a dependency to a maven POM, if IDEA didn't immediately popup a message along the top asking if I wanted to re-import, all it took was a Ctrl-S and it prompted me for that action. Now? I add the dependency..... nothing. Wait.... still nothing. Ctrl-S... nope. Ctrl-S again.... nada.  Oh wait! Finally! An import request.

These are incredibly minor niggles (along with the dozens of others I'm not even mentioning), but it was the attention to these kinds of details that made me fall in love with IDEA at version 2 and have only gotten better with every upgrade... until now. I've always been a huge evangalist of the product to the people I worked with, but right now I can't really recommend it, and that's the first time I haven't been able to do that in seven years.

Seriously, Jetbrains. What's going on?

0

Please sign in to leave a comment.