Copy resourc to output path on save?

Because I am working in Scala, and the compiler is way way to slow to use Make (like I would with java) I typically compile just the file I am editing. In my projects I also edit Drools rules files (with extension *.drl). Also I define Ctrl-S to Build->Compile. In one of my projects when I Compile the *.drl file it is immediatly copied to the output directory. In another project the only way I can get the *.drl file copied over is to do a full Make.

The compiler resources patterns includes "?*.drl". (Of course else the *.drl files would never get copied, not just on a full Make.)

I have saved the full settings and reloaded with the other project, but for the life of me I can't get the *.drl files to copy in the one project. What's more frustrating is that this did used to work -- I've used it a billion times. But now it doesn't.

Is there any specific action that I can bind to a key to force a single resource file to be copied? Or are there any settings that I might be missing?

I would think that this would have to work for when editing *.properties files and such.

-barry

4 comments

I have two projects opened, each with the same settings.

In project-1, the compile action is enabled for *.drl files
In project-2, the compile action is disabled for *.drl files

What could be the reason?

0

Now I have it down to two modules in the same project:

In module-1, the compile action is enabled for *.drl files
In module-2, the compile action is disabled for *.drl files

This is quite strange

0

Ok, I've got it narrowed down to a maven pom.xml dependency.

A third module in the project depends on module-1 via its pom:

    <dependency>
      <groupId>systeminsights</groupId>
      <artifactId>domain</artifactId>
      <version>${project.version}</version>
    </dependency>

Comment out this dependency and *.drl files can be compiled. Uncomment the dependency and *.drl files cannot be compiled. And its not only *drls in the module 'domain' that are effected. This dependency affects the ability to compile *.drl files for the entire project.

Looks like I will have to create a test-case set of projects and submit a bug. Sure hope I can reproduce this in a test-project.

There have been some significant changes to the maven support in the recent maia eaps, probably this is related to those changes...

0

This gets wilder and wilder. If I add a <scope> tag with any value (prod, test, ...) then *.drl compiles are enabled again.

0

Please sign in to leave a comment.