Workaround of generics problem in Pallada 2008, 2013

Hello!

Since 2008 my generics projects have not compiled in IDEA and also in ANT script running under IDEA.

To enable generics compilation back, you need follow changes:
1. Add to your 'generics' library also gjc-rt.jar. Be sure that this jar is above JDK.

2. In compiler settings put to Additional compiler args follow line: -bootclasspath $APPLICATION_HOME_DIR$/lib/generics/collect.jar. Restart IDEA.

3. Check project compilation by Ctrl+F9 and Generics code editing.

4. You also need make some changes in ANT task for generics:

    
      
      
      
    
  
]]>


Good luck!

Please sign in to leave a comment.