JSP Syntax error listed in error (incorrectly)

Hi..I'm running build 2008 and have run across a couple of issues with jsp editing..

1) Similiar to the incorrect errors message in java classes i've seen in the forums...i got error messages in my jsp because it claimed it didnt know the method getAttribute() on the request object. If i edit the file in any way, the errors go away. Even if i just add a blank line to the file, it seemed to fix the parsing and correctly realize there really wasnt an error. So, i can work around this, but its a small hassle.

2) It seems to not recognize objects via the id param in useBean. I have an object defined via useBean id="newData" and anywhere in the jsp i use that object, it shows an error and claims not to know what object newData is. I know this isnt really an error. Is there something i need to do in Idea to help it recognize the useBean id attribute?

I like the 4.0 idea..i had been using Idea since version 2, but tried eclipse in the fall and after messing with it for several months..along with Netbeans, JDeveloper, etc...it was reinforced yet again how much ahead of everyone else intellij is..so i'm back and trying to get used to the differences between idea 3 and 4. I think i have most of it figured out..except for the weird jsp errors idea is claiming (incorrectly)

Anyone know is these are known issues? It will prob be next week before i can upgrade to 2013..

thanks for any help!
-jeff

1 comment
Comment actions Permalink

Please post an SCR into the www.intellij.net/tracker
with small JSP samples helping us to reproduce the problem.
Thanks.

--
regards,
Alexey Kudravtsev
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"Jeff Cunningham" <jcunningham@weather.com> wrote in message news:16282474.1082732093555.JavaMail.itn@is.intellij.net...

Hi..I'm running build 2008 and have run across a couple of issues with jsp editing..

>

1) Similiar to the incorrect errors message in java classes i've seen in the forums...i got error messages in my jsp because it

claimed it didnt know the method getAttribute() on the request object. If i edit the file in any way, the errors go away. Even if i
just add a blank line to the file, it seemed to fix the parsing and correctly realize there really wasnt an error. So, i can work
around this, but its a small hassle.
>

2) It seems to not recognize objects via the id param in useBean. I have an object defined via useBean id="newData" and anywhere

in the jsp i use that object, it shows an error and claims not to know what object newData is. I know this isnt really an error. Is
there something i need to do in Idea to help it recognize the useBean id attribute?
>

I like the 4.0 idea..i had been using Idea since version 2, but tried eclipse in the fall and after messing with it for several

months..along with Netbeans, JDeveloper, etc...it was reinforced yet again how much ahead of everyone else intellij is..so i'm back
and trying to get used to the differences between idea 3 and 4. I think i have most of it figured out..except for the weird jsp
errors idea is claiming (incorrectly)
>

Anyone know is these are known issues? It will prob be next week before i can upgrade to 2013..

>

thanks for any help!
-jeff

>


0

Please sign in to leave a comment.