IDEA 9.0 - Problem with ClearCase integration

I have just upgraded from version 8.1.4 to 9.0 (ultimate), and now I have problems with the ClearCase integration.

When I open my project, I first get a "Reminder" pop-up, saying

"Project started with ClearCase configured to be in the Offline mode."

This happens even when I have switched off "Offline mode" in the settings panel.

Then I press OK, and now a "ClearCase views operation" message pane opens in the bottom, saying

"Error:Plugin failed to collect information on views (absent 'cleartool.exe'?). Plugin is switched to the offline mode.null"

So IDEA has swithed to offline mode for me. I immediately turn it off (again), and check that I can do CC operations. They all work fine.
I close IDEA and re-open it, and the exact same happens again.

I have attached the IDEA.LOG file.
I'm using ClearCase version 7.0.1.1-IFIX02 and the standard "ClearCase Integration" plug-in from JetBrains.

Have anybody else experienced this problem?


Kind regards,
Lars Jacobsen



Attachment(s):
idea.log.zip
5 comments
Comment actions Permalink

Hi,
I do have the same problem, is anyone from Idea's to look into that...
Thanks for your continues support and help.

0
Comment actions Permalink

Update:

Since my first posting the problem has become worse. So-called "View Private" files that are not under source control by ClearCase, are now treated by IDEA as if they actually were. So it attempts to commit them along with files that are actually in ClearCase.

I have tried updating the project (Ctrl-T) and synchronizing with the file system (Ctrl-Alt-Y), but that had no effect.

I have submitted a bug report today with a reference to this thread.

/Lars Jacobsen

0
Comment actions Permalink

There are 2 possible reasons for this failure:
1) you may use UCM view and start IDEA with no ClearCase activity set in this view. Workaround: set current activity externally and reopen the project
2) you may use Base ClearCase, but have the Settings/VersionControl/VCSs/ClearCase/UseUCMModel  option set to 'true' in IDEA. Workaround: uncheck thus option and reopen the project.

See  http://youtrack.jetbrains.net/issue/IDEA-26679

0
Comment actions Permalink

Number 2 is the case. I have unchecked "Use UCM model", and that did the trick.

What about the "Synchronize activities on refresh"? I'm not sure which "activities" this relates to?

br,
Lars

0
Comment actions Permalink

Bump - I have the same questions...

0

Please sign in to leave a comment.