Tomcat Debugging not working

Hi,

I have Intellij 8.1.3 and Tomcat 6.0.
I start Tomcat from command line in debug mode on port 5001.
When I hookup to that port from Intellij, it hooks up. But all the break points show as invalid.
I have made sure there are no classes/jars within Intellij. but still see this issue.

Any suggestions would be great help.

Thanks
Raghu

10 comments

What's ur JDK version? 6u14 & 6u15 has a bug that cannot stop at the breakpoint, which has been fixed at 6u16.

0

Thanks a lot for the quick response.

I tried the jdk 6.16. but did not work. I was using jdk 1.5.17 earlier.(in intellij)
Please let me know if there could be some other possibility.
Thanks
Raghu

0

Do you put breakpoint in java or jsp files? Are you sure that debug info generation is not disabled? Which kind of run configuration do you use to
connect to Tomcat ("Remote" or "Tomcat Remote")?

Hi,

I have Intellij 8.1.3 and Tomcat 6.0.
I start Tomcat from command line in debug mode on port 5001.
When I hookup to that port from Intellij, it hooks up. But all the break points show as invalid.
I have made sure there are no classes/jars within Intellij. but still see this issue.

Any suggestions would be great help.

Thanks
Raghu

---
Original message URL: http://www.jetbrains.net/devnet/message/5245539#5245539



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

I put break points in java.I am using Remote configuration to connect to Tomcat.
Can you please tell me how to check on "debug info generation is not disabled"?

When I put a break point anywhere in java code, it turns to X mark.

I have used debugging with jboss,weblogic etc in earlier versions of intellij.

Thanks
Raghu



Attachment(s):
debug.jpg
0

Can someone please help me?

Thanks
Raghu

0

What error message is shown in tooltip for the invalid breakpoint?
How do you compile your project? If you compile it by using IDEA make sure that "Generate debugging info" checkbox (File | Settings | Compiler |
JavaCompiler) is marked. If you compile it by ant check that 'debug' attribute of 'javac' task set to 'on'.

Can someone please help me?

Thanks
Raghu

---
Original message URL: http://www.jetbrains.net/devnet/message/5245656#5245656



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

I'm curious, if you are running a local install of Tomcat, why are you using a remote configuration, and a generic one at that? If you simply create a local tomcat configuration, you can than start it using the debug button. It seems to me that that is much simpler and avoids the configuration problems that is sounds like you are having.

0

That was an excllent suggestion.
I put the debug on in my ant's javac task and it worked beautifully.

Thanks a lot.
I have again started loving Intellij like earlier

Thanks
Raghu

0

In the cold weather, the UGG boots are considered as the best shoes.More and more people like wearing the UGG boots such as the UGG Classic Metallic 5812]]>.With its development ,the UGG boots have lauched different kinds of boots into the fashion market,including the UGG Classic Short Boots]]> and the UGG Women's Highkoo]]>.However,in the fashion world,if you want to be more attractive and elegant,the beautiful shoes are not enough.You have to choose the best stylish handbag to match your shoes.Therefor,the designer replica handbags are very necessary.If you want to buy the best designer cheap handbags,i would like to introduce two famous brand handbags to you.I think there must be one handbag is your favorite.One is the famous brand Versace Handbags ,the other is the Ferragamo Handbags.Both of them are the famous brand in the world.Their quality are very good.

---
Original message URL: http://www.jetbrains.net/devnet/message/5254898#5254898

-1

Hello Nicolay,

I have the same problem with debugging Local Tomcat configuration.

As you've advised to Raghu, I've checked "Settings ->Compiler->Java Compiler -> Generate debugging info check-box.

But this action didn't take affect: I'm still see breakpoints marked with cross.
In the tooltip I can see the following message:

"   Line 35 in Login.execute()(my.sample.servlet)
   Warning: No executable code found at line 35 in class my.sample.servlet.Login
    Suspend: all;
    Log message: No;
"

Can you advise something to make breakpoints work?
0

Please sign in to leave a comment.