Pallada dependent web module support

Is this supposed to be implemented in build 2002? Doesn't appear to be but
the change log says it is.


7 comments
Comment actions Permalink

I found it partially working for the setup of my project with a bug on
not recognizing jsp includes that I filed today--
http://www.intellij.net/tracker/idea/viewSCR?publicId=31075

Jon

Brad wrote:

Is this supposed to be implemented in build 2002? Doesn't appear to be but
the change log says it is.

0
Comment actions Permalink

The problem I'm seeing is that I have a module that defines a taglib and
another module that uses the taglib. I setup the dependency but when I try
to use the taglib in a jsp, it is marked red. Anyone else see this? Should I
file a bug?

"Jon Steelman" <jon@cc.gatech.edu> wrote in message
news:c49q76$vck$1@is.intellij.net...

I found it partially working for the setup of my project with a bug on
not recognizing jsp includes that I filed today--
http://www.intellij.net/tracker/idea/viewSCR?publicId=31075

>

Jon

>

Brad wrote:

Is this supposed to be implemented in build 2002? Doesn't appear to be

but

the change log says it is.



0
Comment actions Permalink

Brad wrote:

The problem I'm seeing is that I have a module that defines a taglib and
another module that uses the taglib. I setup the dependency but when I try
to use the taglib in a jsp, it is marked red. Anyone else see this? Should I
file a bug?

I'd like to be able to run web modules period. Filed the bug already.
So until this works, I can't verify your problem on my end, it's a waste
of time.

I know JB says that J2EE is always broken because they don't use J2EE,
but that statement in itself is turning into an old broken record. Hire
1 QA guy which can check on these things before releasing or something.

It's getting annoying.

R

0
Comment actions Permalink

Brad - now that you point it out, I see the problem. But after
experimenting a little, I only see it when the .tld is in both the
modules-- just like the problem I filed for jsp includes. Do you only
find the problem when the .tld's are in both the original and the
dependent module?

Jon

Brad wrote:

The problem I'm seeing is that I have a module that defines a taglib and
another module that uses the taglib. I setup the dependency but when I try
to use the taglib in a jsp, it is marked red. Anyone else see this? Should I
file a bug?

"Jon Steelman" <jon@cc.gatech.edu> wrote in message
news:c49q76$vck$1@is.intellij.net...

>>I found it partially working for the setup of my project with a bug on
>>not recognizing jsp includes that I filed today--
>>http://www.intellij.net/tracker/idea/viewSCR?publicId=31075
>>
>>Jon
>>
>>Brad wrote:
>>
>>>Is this supposed to be implemented in build 2002? Doesn't appear to be


but

>>>the change log says it is.


0
Comment actions Permalink

I don't think it's in both but I'll check again later. I just went back to
4.0.2 to get some work done.

"Jon Steelman" <jon@cc.gatech.edu> wrote in message
news:c49r6v$4m6$1@is.intellij.net...

Brad - now that you point it out, I see the problem. But after
experimenting a little, I only see it when the .tld is in both the
modules-- just like the problem I filed for jsp includes. Do you only
find the problem when the .tld's are in both the original and the
dependent module?

>

Jon

>

Brad wrote:

>

The problem I'm seeing is that I have a module that defines a taglib and
another module that uses the taglib. I setup the dependency but when I

try

to use the taglib in a jsp, it is marked red. Anyone else see this?

Should I

file a bug?

>

"Jon Steelman" <jon@cc.gatech.edu> wrote in message
news:c49q76$vck$1@is.intellij.net...

>
>>I found it partially working for the setup of my project with a bug on
>>not recognizing jsp includes that I filed today--
>>http://www.intellij.net/tracker/idea/viewSCR?publicId=31075
>>
>>Jon
>>
>>Brad wrote:
>>
>>>Is this supposed to be implemented in build 2002? Doesn't appear to be
>

but

>
>>>the change log says it is.
>
>
>



0
Comment actions Permalink

I'd suggest you file a bug report when you discover the way the problem
shows up.

Jon

Brad wrote:

I don't think it's in both but I'll check again later. I just went back to
4.0.2 to get some work done.

"Jon Steelman" <jon@cc.gatech.edu> wrote in message
news:c49r6v$4m6$1@is.intellij.net...

>>Brad - now that you point it out, I see the problem. But after
>>experimenting a little, I only see it when the .tld is in both the
>>modules-- just like the problem I filed for jsp includes. Do you only
>>find the problem when the .tld's are in both the original and the
>>dependent module?
>>
>>Jon
>>
>>Brad wrote:
>>
>>
>>>The problem I'm seeing is that I have a module that defines a taglib and
>>>another module that uses the taglib. I setup the dependency but when I


try

>>>to use the taglib in a jsp, it is marked red. Anyone else see this?


Should I

>>>file a bug?
>>>
>>>"Jon Steelman" <jon@cc.gatech.edu> wrote in message
>>>news:c49q76$vck$1@is.intellij.net...
>>>
>>>
>>>>I found it partially working for the setup of my project with a bug on
>>>>not recognizing jsp includes that I filed today--
>>>>http://www.intellij.net/tracker/idea/viewSCR?publicId=31075
>>>>
>>>>Jon
>>>>
>>>>Brad wrote:
>>>>
>>>>
>>>>>Is this supposed to be implemented in build 2002? Doesn't appear to be
>>>
>>>but
>>>
>>>
>>>>>the change log says it is.
>>>
>>>
>>>


0
Comment actions Permalink

The web module API has changed drastically in 2002, and from what I can tell it's not currently possible to ask IDEA about stuff like the path to exploded jar, whether a war is built, etc. I'm assuming that this will be re-exposed in some form or another sooner rather than later.

0

Please sign in to leave a comment.