IntelliJ debugging very slowly with my project in snow leopard

I've noticed that 9.0 CE for some reason is debugging my project very slowly when running under Snow Leopard.

In my case I'm using the java 1.6.0 VM and when I set a break point on any method once it hits the break point when I "next" over the break point it takes a very long time to continue executing.

I've since set up the same project under Eclipse and I'm not noticing this behaviour. I'm also seeing no delays when I use the 1.5.0 JVM under snow leopard. (not the link but the restored 1.5.0 JDK from Leopard)

If I run and not debug there is no delays.

I can also set a break point _after_ the line that I'm nexting over and it will quickly get to the break point. It's only when I am "next" over the break point that I notice these delays.

There is no delays in Eclipse nor if I run and not debug in IntelliJ. I takes 12 minutes to configure my Hibernate Configuration if I'm nexting over it whereas if I run over it it's configured in other a second.

Very strange.

2 comments
Comment actions Permalink

Search for method breakpoints, they slow down debugging tremendously

On 13.01.2010 8:32, Robert Nicholson wrote:

I've noticed that 9.0 CE for some reason is debugging my project very slowly when running under Snow Leopard.

>

In my case I'm using the java 1.6.0 VM and when I set a break point on any method once it hits the break point when I "next" over the break point it takes a very long time to continue executing.

>

I've since set up the same project under Eclipse and I'm not noticing this behaviour. I'm also seeing no delays when I use the 1.5.0 JVM under snow leopard. (not the link but the restored 1.5.0 JDK from Leopard)

>

If I run and not debug there is no delays.

>

I can also set a break point after the line that I'm nexting over and it will quickly get to the break point. It's only when I am "next" over the break point that I notice these delays.

>

There is no delays in Eclipse nor if I run and not debug in IntelliJ. I takes 12 minutes to configure my Hibernate Configuration if I'm nexting over it whereas if I run over it it's configured in other a second.

>

Very strange.

>

---
Original message URL: http://www.jetbrains.net/devnet/message/5254139#5254139



--
Best regards,
   Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Yeah when I notice this behaviour there are no breakpoints other than the line breakpoint that i'm breaking on for my test. so it's when I "next" over the line i'm broken at that I notice that it executes considerably slower than had the breakpoint not been there.

I just performed the same demonstration to a work collegue where I show him the project in IntelliJ running and I have a line breakpoint on a line and a breakpoint on the very next line. It takes forever for a simple "light" method to get to the next breakpoint when I "next"

when I do the same test in Eclipse there is no delay whatsoever.

very very very strange.

0

Please sign in to leave a comment.