IntelliJ IDEA 9 no longer has "Deploy web applications to server after compilation"?

Previous to version 9, there was an option in Settings->Compiler, "Deploy web applications to server after compilation"

It's no longer there.

How do I tell IntelliJ to not deploy my web application after compilation?

It's frustrating because if I try to just copy up one file of my webapp, it makes tomcat unusable because it tries to deploy the web app along with it.

5 comments
Comment actions Permalink

Anyone know if that feature was moved or removed completely?

0
Comment actions Permalink

I saw those options in the runtime configurations.  Thank you for letting me know about them via the runtime window and hotkey .

However, when I hit ctrl-shift-f9 to either compile a class or copy an xhtml file to the running application, it continues to give an error after a few seconds:

HTTP Status 503 - This application is not currently available

With 8.1.x, I was able to set "Deploy web applications to server after compilation" to never and set "Settings->Debugger->HotSwap->Reload classes after compilation" to Always.  Then when I would hit ctrl-shift-f9, it wouldn't give that error in the web application.

I tried all three options in the link you suggested - Update resources, Update classes and resources, and Redeploy - and all of them had the same effect.

I'm afraid that I'll have to revert back to 8.1.x until this gets addressed because I can't waste any more time restarting my app for every page update or trivial class change.

0
Comment actions Permalink

Do you have option "Build on make" enabled in your artifact settings? If so ctrlshiftf9 on java class may lead to building the whole artifact.
However, Ctrl+F10 (Update) action should work anyway. Could you please provide more details? As far as I understand you start Tomcat, then change some
resource or java file and press Ctrl+F10, right? Do you use local or remote Tomcat configuration? Do you deploy exploded directory or war file?

I saw those options in the runtime configurations.  Thank you for letting me know about them via the runtime window and hotkey .

However, when I hit ctrl-shift-f9 to either compile a class or copy an xhtml file to the running application, it continues to give an error after a few seconds:

HTTP Status 503 - This application is not currently available

With 8.1.x, I was able to set "Deploy web applications to server after compilation" to never and set "Settings->Debugger->HotSwap->Reload classes after compilation" to Always.  Then when I would hit ctrl-shift-f9, it wouldn't give that error in the web application.

I tried all three options in the link you suggested - Update resources, Update classes and resources, and Redeploy - and all of them had the same effect.

I'm afraid that I'll have to revert back to 8.1.x until this gets addressed because I can't waste any more time restarting my app for every page update or trivial class change.

---
Original message URL: http://www.jetbrains.net/devnet/message/5253859#5253859



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Looks like I had something wrong with my setup.  I tried your suggestion with the blog post and it seems to work fine now - both hotswapping classes and copying resources over to the exploded war.

Thank you for the help.  That was quite frustrating.

0

Please sign in to leave a comment.