GuiDesigner Sample Not Working

I have gone through online training for Gui designer
and using the instructions i have developed
the form(Subscriber form)
but i am getting problems while running it

then i downloaded the souce code and according to the instructions given in it i have run the application
but still i m getting same problem

is it a bug ???
the following is the error message i m getting while running



6 comments

Er, under which JDK version you're trying to run it? From the error messege, it seems like you compiled it under 1.4 (class version 48.0) but it's trying to run it under 1.3 or less.

0

Er, under which JDK version you're trying to run it?
From the error messege, it seems like you compiled it
under 1.4 (class version 48.0) but it's trying to run
it under 1.3 or less.


hello! i just clicked run
ie. it will compile and run
then it defintely uses only on jvm, right

any ways
how could idea allow two setting for the same project ???

cheers,

shekar



this idea4 has changed a lot
it takes some time to understand


now i m installing jdk1.4 to test the application

any help is still appreciated

0

i laa !!!
it works with jdk1.4

thx. Marcus Brito
but u need to be cool after all i m trainee programmer
and this idea4 interface is bit complicated


cheers
shekar

0

IDEA won't allow you to specify different compile/run JDK's, but you can trick it by specifying a JDK, doing a full rebuild, changing the JDK and then running the app. That's not what I expected you to be doing, however :)

My guess was also a bit wrong; since the VM was complaining about a GUI builder class (not a project class), it means that the GUI builder was compiled under 1.4 and thun can only be run under a 1.4 (or later) JVM.

0

By the way, if you feel confused or intimidated by IDEA interface, please express your opinions here. IDEA folks are always trying to provide us with the best user interface possible and newbie impressions are sure welcome :)

0

My guess was also a bit wrong; since the VM was
complaining about a GUI builder class (not a project
class), it means that the GUI builder was compiled
under 1.4 and thun can only be run under a 1.4 (or
later) JVM.


thx. again

0

Please sign in to leave a comment.