Subversion authentication in Snow Leopard 10.6.1

I recently switched to a Macbook Pro running 10.6.1 Snow Leopard for my development. I'm on build 9886 of IntelliJ You might say I'm stilll experiencing some growing pains. I have Intellij using JDK 1.6 64-bit but I'm having problems with Subversion authentication. Intellij never pops up a dialog asking for my credentials causing a sever timeout. I don't think I'm doing anything wrong but OS X configuration is a little different to what I'm used to on Linux. Thanks.

10 comments
Comment actions Permalink

I'm on build 9886 of IntelliJ


You could try to update to 9939 and see whether it works better.

0
Comment actions Permalink

Yeah, I tried the latest EAP and it produced the same result, a server timeout. I think there are some incompatibilities that need worked out. I can use the command-line svn client in OS X from a terminal but Intellij won't do it from the IDE. I'll stick with my Linux install for Java development until I hear more. I did some searching and didn't come up with much.

0
Comment actions Permalink

Maybe it would help the Jetbrains support, if you could provide more details
about your authentication type?

0
Comment actions Permalink

Not a problem. I'm hoping someone from Jetbrains will comment, it looks like a legitimate issue and not a misconfiguration on my part. I also tried the 8.1.4 RC with no change in behavior. My subversion URL uses the https scheme. I authenticate against Active Directory using basic authentication. That's about it. No errors in the logs, just a server timeout. I checked out my files using the OS X svn client and created a new IntelliJ project. It picked up I was using subversion but no luck connecting to the server when I wanted to update or commit from the IDE. Below is the error I receive. Thanks

Error:svn: timed out waiting for server
svn: OPTIONS request failed on '/svn/icfdev/NE-FIMS/trunk/Permits-ejb'

Grant

0
Comment actions Permalink

I thought I would follow-up and report this was not a problem with Intellij. I tracked it down to a DNS resolution problem with Cisco Anyconnect and OS X. I'm stuck using IP address for now until Apple or Cisco fix the problem.

Does anyone happen to know how I can clear out the Repository URL drop-down list in IntelliJ. I now have 5 or 6 entries that are wrong. I tried invalidating the caches but that doesn't work. I might have to edit a file if I knew which one but I don't on OS X. Anyone?

0
Comment actions Permalink

I spoke too soon on the subversion problems. It remains a problem for me. I can browse subversion repositories from IDEA that do not require authentication. I obseve different behavior on OS X from my Linux machine. On the Linux box IDEA pops up a dialog asking me for my user name and password when I access my corporate subversion repository over https. On the OS X box it does not and eventually times out. I tested with the latest EAP released today. Still no go so I created an issue in the tracker for it. At the same time IDEA is timing out Firefox is browsing the same repository so the problem is not network or connection related.

0
Comment actions Permalink

Can you add the ip to /etc/hosts as a workaround until DNS resolution is fixed?

0
Comment actions Permalink

Similar case here:  Snow Leopard, IDEA 9

Pops up a pink bubble saying "Problem storing Subversion credentials..."

0
Comment actions Permalink

I'm having the same problem.  Additionally, it takes a super long time to open projects sometimes.  I think it may be because of some svn activity going on during the loading of a project (which I don't have a connection to unless my vpn is running...).  Little snitch tells me that my svn server is being accessed during the loading of the project.  Is there a way to stop the loading of a project from blocking on svn server access or whatever it's doing there?  Is there something I can disable to solve this problem?

0
Comment actions Permalink

Could you please try to use IDEA 9.0.1 EAP
(http://www.jetbrains.net/confluence/display/IDEADEV/Maia+EAP) which
should have several svn issues fixed.

On 29.12.2009 22:21, Daniel Spangler wrote:

I'm having the same problem.  Additionally, it takes a super long time to open projects sometimes.  I think it may be because of some svn activity going on during the loading of a project (which I don't have a connection to unless my vpn is running...).  Little snitch tells me that my svn server is being accessed during the loading of the project.  Is there a way to stop the loading of a project from blocking on svn server access or whatever it's doing there?  Is there something I can disable to solve this problem?

>

---
Original message URL: http://www.jetbrains.net/devnet/message/5253404#5253404



--
Best regards,
   Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.