How to get Griffon project working

So I'm using Intellij IDEA 9 BETA and I'm trying to create a griffon project (from scratch):

1. Select File -> New Project
2. Select "Create project from scratch"
3. Give a name and choose "Griffon Application" under the type
4. Click "next", select Griffon version (0.2 in my case)
5. The project gets created but it doesn't create any griffon stuff. I get a project with an empty "src" directory and no "facets" defined.

If I create the project using the griffon command-line and then "open project" (point it to the .ipr file that griffon creates) it opens up but it says "can't determine type of project will treat as java"...but it does show the "griffon view" that I can use.

I'm on Linux (Mint 7 specifically).

2 comments
Comment actions Permalink

Looks like Griffon 0.2 is not supported.  Is that true?  I ran into the same issue with the release version of Griffon 0.2 - Empty project created, no Griffon artifacts generated. Performed the same project steps pointing at Griffon 0.1.1 and it ran the create-app command for me and generated Griffon artifacts.  Have you heard any official word from Jetbrains on this?

0
Comment actions Permalink

No i haven't heard anything, although I haven't tried since IntelliJ IDEA 9 is officially available. I'm also now on a Windows 7 computer so I'll have to give it a shot some time soon.

0

Please sign in to leave a comment.