Trouble upgrading Tomcat project to Idea 9.0 - missing j2ee.jar

I'm having trouble upgrading my Tomcat-based project to Idea 9.0. The issue is that it depends on the j2ee.jar, which used to be included in the $IDEA_HOME/lib directory. I read http://youtrack.jetbrains.net/issue/IDEA-23710, which seems to imply that the jar should be auto-downloaded as needed, but this isn't happening.

What is the recommended/preferred way of dealing with this?

1 comment
Comment actions Permalink

I too am having this issue. I just upgraded from 8.1.4 to 9.0. When I upgraded the installer queried about importing settings from the existing install. Apparently none of my previous settings have been imported.

0

Please sign in to leave a comment.