OS X 10.6.2 and recommended java version to use

Hi,

  By default, 10.6.2 does not come with JDK 1.5. Of course, since I run with JDK 5 as well, I hacked installed it. In IntelliJ, the version specified is 1.5*, which means that if I hacked installed 1.5, it will run with it.

  What is the recommended JDK to run IntelliJ on a mac? I am using IDEA 9 Beta, but would love to know also for 8. What do you guys test most with?

Cheers,
Shay

2 comments
Comment actions Permalink

Of course, since I run with JDK 5 as well, I hacked installed it.


Most likely you now have a corrupt Java installation on your Mac. :(

--
Tom

0
Comment actions Permalink

Hello kimchy,

By default, 10.6.2 does not come with JDK 1.5. Of course, since I
run with JDK 5 as well, I hacked installed it. In IntelliJ, the
version specified is 1.5*, which means that if I hacked installed 1.5,
it will run with it.

What is the recommended JDK to run IntelliJ on a mac? I am using
IDEA 9 Beta, but would love to know also for 8. What do you guys test
most with?


On Snow Leopard, we definitely recommend the default 32-bit JDK 1.6 installation,
rather than any hacked 1.5 install.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.