Stepping speed in Debugging slower again in 1159

We seem to have lost some if not all of the performance increase that
went in a few builds ago :(

Anyone else seeing this too?

N.

ps. I have checked - no alternate views for collections on, no watches
set up, suspend all threads unchecked.

6 comments
Comment actions Permalink

What was the last build where the perfomance was acceptable for you?

0
Comment actions Permalink

Must be something else than last time. For me debugging is still very quick (while a couple of builds ago it was slooow).

0
Comment actions Permalink

i was complaining about it ...
now it seems ok .. but for some reason .. the system goes freeezin from time to time and in the status bar i get this message saying it's waiting for a thread to complete its execution

when ever i have to hi the debug button i hit it very nervously with no confidence wondering if it will go freeeezin :(

parthi.

0
Comment actions Permalink

Maybe you haven't turned on the "Supsend all threads while stepping" option and another thread is eating your CPU's time? (See bottom-left button in the debugger tab.)

0
Comment actions Permalink

This means that you have either turned on 'toString()' or alternative collection or watch some expression. It's unsafe to terminate method invocations, debugger waits until the method exits.

0
Comment actions Permalink

I remember that in build 1136, stepping was almost instantaneous. Using
it earlier in 1159, stepping was pausing once more between lines, maybe
only quarter or half a second, but it all adds up. Probably not as bad
as it used to be, but it's a real shame that it's got worse again
compared to the pleasure that was 1136!

N.

ps. I also have no "toString"s configured.

Alexei Nikitin wrote:

What was the last build where the perfomance was acceptable for you?

0

Please sign in to leave a comment.