How do I get Font antialiasing/subpixel smoothing in 64bit Linux? (IDEA 8.1.4)

I can't seem to get the editor fonts to be antialiased.  I've checked the "Use antialiased Font" and it appears to be doing nothing" Using the nimbus look&feel I'm able to get the menu fonts to look decent, but the editor fonts are still really ugly.  Both Eclipse and Netbeans render quite nicely with decent fonts.

How do I get good font antialiasing/subpixel smoothing?  Its not an attractive solution as it is.

Ubuntu 9.10
java-6-sun
64bit
Intellij Idea 8.1.4



Attachment(s):
Idea-Bad editor fonts.png
editor.png
1 comment
Comment actions Permalink

So it turns out that I had mistakenly edited the idea.properties file and changed
idea.use.default.antialiasing.in.editor=false
to true  (don't do this!!  It will completely turn off anti-aliasing!)

I totally misread/misunderstood it from an article that I read online.

It turns out that the right solution was to add an argument to the idea.vmoptions file
-Dawt.useSystemAAFontSettings=lcd
I also threw in the -Dswing.aatext=true parameter just for good measure just in case I map the wrong jdk in the future.

I tried the various settings as found here but found that the lcd settings worked the best for me.

0

Please sign in to leave a comment.