Safe Delete not working correctly

When I attempt to safely delete a field in a class, 1144 seems to do a straight string search rather than an attribute search and comes up with occurrences that have nothing to do with the attribute needing to be deleted. Then, I go through the list and exclude the ones I am not interested in (and which should be in the list anyway) and I cannot find the 'Do Refactor' button. So, I hit the 'Rerun Safe Delete' button and guess what happens? It repeats the whole process over again!! This used to work (I cant remember how long ago) and it needs to work before IDEA is released.

3 comments

Saqib wrote:

When I attempt to safely delete a field in a class, 1144 seems to do a
straight string search rather than an attribute search and comes up with
occurrences that have nothing to do with the attribute needing to be
deleted. Then, I go through the list and exclude the ones I am not
interested in (and which should be in the list anyway) and I cannot find
the 'Do Refactor' button. So, I hit the 'Rerun Safe Delete' button and
guess what happens? It repeats the whole process over again!! This used to
work (I cant remember how long ago) and it needs to work before IDEA is
released.


Saquib,
I cannot reproduce this. Post at least a screenshot here.

Friendly,
Dmitry
--
Dmitry Lomov
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0

I think accidentally posted this bug twice!! Sorry
It is the Refactor->Safe Delete that did not work. I will try to repeat it and post a screen shot.

0

Hi Dmitry.

Here is a link to the duplicate which has a screenshot showing the problem.

http://www.intellij.net/forums/thread.jsp?forum=22&thread=74240#803145

0

Please sign in to leave a comment.