Could you please make JDK 1.5 compiler work

JDK 1.5 copiler would not start due to invalid command line switches. Can it
possible be fixed?

-


Sun has a mechanism in place now to get you an alpha of the entire J2SE 1.5
platform every two weeks (linux, solaris, and windows). This will give you a
chance to try out the new language features and APIs.

To sign up, send e-mail to Ingrid.Yao@sun.com, asking to be added to the CAP
program. Tell her Neal Gafter sent you to sign up. She will send you a
nondisclosure form to sign and FAX back. Once she gets it back from you
you'll get access to a web site that has a new alpha of the entire J2SE
platform (solaris, linux, and windows) every two weeks.
-




21 comments

Hi,

the same problem here...
Please fix this !

Greets -Ralf-

0

Hi,

the problem is that with the jdk 1.5beta aurora won't compile correctly.

0

Yes, but in order to fix the problem one still needs JDK 1.5 :), getting it is not very simple (send email, sign NDA, fax it, etc) so I've suggested more convenient way to do it.

0

Hi,

I think the guys from IntelliJ know where to get the JDK :)

Merry Xmas !

Greets -Ralf-

0

Maybe this public alpha release of J2SE 1.5 should make the JetBrainers think about shipping aurora with support for the 1.5 new features.

When Aurora is out (late january, I'd guess) J2SE 1.5 will already be widely spread and used by early enthusiasts, maybe even by a few companies aiming a far shot. Better rethink that thing about releasing Aurora without support for 1.5...

0

Ugh, this is why so many of you people don't deserve any sort of early preview for anything. Sun has said that the 1.5 release is a pre-alpha, if anyone is using it in a more involved manner than download/install/forget, then they should at least have the decency not to whine for IDEA (or ANY tool) to support it.

It's funny, I had a bet with someone that within 2 days, morons here will start saying stuff like 'IDEA breaks with the 1.5alpha jdk, please fix it!'. I lost the bet; it only took one day.

0

Hani Suleiman wrote:

Ugh, this is why so many of you people don't deserve any sort of early preview for anything. Sun has said that the 1.5 release is a pre-alpha, if anyone is using it in a more involved manner than download/install/forget, then they should at least have the decency not to whine for IDEA (or ANY tool) to support it.

It's funny, I had a bet with someone that within 2 days, morons here will start saying stuff like 'IDEA breaks with the 1.5alpha jdk, please fix it!'. I lost the bet; it only took one day.


Um, ok while I agree that it's lame to ask for alpha anything to be
supperted/fixed, calling people morons is not cool, don't care how
pissed, irked, or on the edge you might be.

Tone it down dude.


R

0

Hani Suleiman wrote:

>Ugh, this is why so many of you people don't deserve any sort of early preview for anything.
>

You shouldn't crosspost between the bileblog and the EAP forums,
especially the day before Christmas.

Alain

0

Yes, but in order to fix the problem one still needs JDK 1.5 :), getting it is not very simple (send email, sign NDA, fax it, etc)...


it's simple since today:
http://java.sun.com/developer/earlyAccess/j2sdk150_alpha/
the filename even says beta

0

A stupid request on Christmas (or the day before) is still a stupid request.

0

True, but in the spirit of forgiveness the comment could have been milder.
:)

Andrei

"Hani Suleiman" <hani@formicary.net> wrote in message
news:27752431.1072280062210.JavaMail.itn@is.intellij.net...

A stupid request on Christmas (or the day before) is still a stupid

request.


0

Using attached patch IDEA 1024 compiles with Java 1.5.
Option 'Use generic-enabled compiler' should NOT be set.



Attachment(s):
idea_rt.jar
0

And this patch enables 1.5 features (generics, etc),
since by default compiler assumes 1.4 (or less) java version for source



Attachment(s):
idea_rt.jar
0

Hi All,
we have not yet reached a decision as to the level of support for 1.5
we will have in initial Aurora release.

At any rate, IDEA is not at the moment fully aware of all 1.5 language
features. We plan to provide support for them in series of releases
after Aurora, going along as 1.5 matures.

We will keep you posted of our plans.

Friendly,
Dmitry

Alex Roytman wrote:

JDK 1.5 copiler would not start due to invalid command line switches. Can
it possible be fixed?

--------------------------------------
Sun has a mechanism in place now to get you an alpha of the entire J2SE
1.5 platform every two weeks (linux, solaris, and windows). This will give
you a chance to try out the new language features and APIs.

To sign up, send e-mail to Ingrid.Yao@sun.com, asking to be added to the
CAP program. Tell her Neal Gafter sent you to sign up. She will send you a
nondisclosure form to sign and FAX back. Once she gets it back from you
you'll get access to a web site that has a new alpha of the entire J2SE
platform (solaris, linux, and windows) every two weeks.
--------------------------------------


--
Dmitry Lomov
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0

When do you think IDEA 4 is going to be released? When do you think the release with 1.5 and aspectJ (IDEA 4.1?) will be released?

0

Hi,

does this patch only run with 1024 or also with later builds ?

0

Yes, it works with later version (tested with 1032 so far). However, JetBrains changes to idea_rt.jar will require it to be updated or even eliminated at all. So, please, consider patch applicable if the size of idea_rt.jar before modification is 85646 bytes.

0

Sounds fair for me. I'd like to see some kind of support like what's there for AspectJ: it exists, it kinda works, but we don't "officially" advertise it.

0

bet with someone that within 2 days, morons here will
start

I lost the bet; it only took one day.


you seem hardly in a position to call people morons if
you dont even undersatnd that you should have won the
bet...

haha,slip

0

Please sign in to leave a comment.