11 comments

Thanks for the heads-up - downloading now! Can't wait to start using it!

Best regards,
Lars Ugleberg

0

Lars Ugleberg wrote:

Thanks for the heads-up - downloading now! Can't wait to start using it!

Best regards,
Lars Ugleberg



It looks to me like build 1138 at least doesn't like working with 1.5. The
issue appears to be that Aurora really wants the collection support to be
externalized the way it is with a 1.4 + gjc setup.

Presumably this is pretty easy to deal with.

--
Ted Dunning

0

You probably don't want to use IDEA's generics support until they update to support the new variance syntax. See http://intellij.net/forums/thread.jsp?forum=22&thread=73433&tstart=0&trange=15#798787 for details.

0

Keith Lea wrote:

You probably don't want to use IDEA's generics support until they update
to support the new variance syntax. See

>
http://intellij.net/forums/thread.jsp?forum=22&thread=73433&tstart=0&trange=15#798787

for details.



Thanks for the pointer, but I think that my estimate of my
interest is higher than your estimate. I trust my estimate
better as well.

I am interested in seeing 1.5 support work regardless of how
many warts it has off the bat. I haven't used 1.5 more than
in play and am very interested in getting started with it
now that the beta is available. With IDEA is better than
without in my mind even with some defects.


--
Ted Dunning

0

I'm very excited about generics and autoboxing and enums, but I don't plan to use them until IDEA supports them without marking my code all red and yellow. :)

0

It looks to me like build 1138 at least doesn't like
working with 1.5. The issue appears to be that Aurora
really wants the collection support to be
externalized the way it is with a 1.4 + gjc setup.

Presumably this is pretty easy to deal with.
--
Ted Dunning


Can anybody give an estimate when IDEA can be run with 1.5?

0

JetBrains,

Here's some extra incentive to wrap up 4.0.0 and get working on eap for 4.x with 1.5 language suport.
I just received this email from CodeGuide and they claim to be the first to support 1.5.0 language features.

-Alex

-


Dear Alex!

The release of Sun's Java 2 SDK 1.5.0 is close. There already is
an official beta release available. Are you prepared?

CodeGuide 6.1 is the first IDE that fully supports the
J2SDK 1.5.0 beta and all the new language features such as:

  • Generic types with wildcards

  • Autoboxing

  • Enums

  • Foreach statements

  • Static imports

  • Varargs

  • Metadata syntax


CodeGuide also includes the "Generify" refactoring to easily
convert your sourcecode to make use of the new language
features.


Resources:

  • CodeGuide 6.1 information and download:

http://www.omnicore.com

  • Introduction to the new language features:

http://www.omnicore.com/htmls/newlanguage.html

  • Sun J2SDK 1.5.0 beta download:

http://java.sun.com/j2se/1.5.0/index.jsp


Best regards,


The CodeGuide team
Omnicore Software
www.omnicore.com

---
You are receiving this mail because you downloaded a previous
version of CodeGuide. If you do not wish to receive further
emails from us concerning news or product updates please reply
to this mail with REMOVE in the subject line and we will remove
you from our mailing list immediately.

0

Looks interesting - I may check it out. Now that 1.5 is out, I can't
wait to try some of the new stuff... At least until 4.1 is out.

Alex wrote:

JetBrains,

Here's some extra incentive to wrap up 4.0.0 and get working on eap for 4.x with 1.5 language suport.
I just received this email from CodeGuide and they claim to be the first to support 1.5.0 language features.

-Alex

-----------------------------------------------------
Dear Alex!

The release of Sun's Java 2 SDK 1.5.0 is close. There already is
an official beta release available. Are you prepared?

CodeGuide 6.1 is the first IDE that fully supports the
J2SDK 1.5.0 beta and all the new language features such as:

  • Generic types with wildcards

  • Autoboxing

  • Enums

  • Foreach statements

  • Static imports

  • Varargs

  • Metadata syntax


CodeGuide also includes the "Generify" refactoring to easily
convert your sourcecode to make use of the new language
features.


Resources:

  • CodeGuide 6.1 information and download:

http://www.omnicore.com

  • Introduction to the new language features:

http://www.omnicore.com/htmls/newlanguage.html

  • Sun J2SDK 1.5.0 beta download:

http://java.sun.com/j2se/1.5.0/index.jsp


Best regards,


The CodeGuide team
Omnicore Software
www.omnicore.com

---
You are receiving this mail because you downloaded a previous
version of CodeGuide. If you do not wish to receive further
emails from us concerning news or product updates please reply
to this mail with REMOVE in the subject line and we will remove
you from our mailing list immediately.


0

I tried 1144 with 1.5.0 beta. Idea starts nicely but I can't open my source files for editing.

0

Hello,

Build 1144 work with 1.5.0-beta very well, however Aurora is "Official
Unsupported JDK 1.5" before 4.1.

I use, JDK 1.5.0-beta (build 1.5.0-beta-b31), IntelliJ IDEA build 1141, in
libraries i have NOT any generics jars (collect.jar, gjc-rt.jar), in
compiler settings i have unchecked "Use generics-enabled compiler", and
"-source 1.5" in "Additional Javac command line parameters".

Follow code compiled (Ctrl + Shift + F9) success:

 list = new ArrayList();
    list.add("String");
    String value = list.get(0);
  }
}
]]>


Thanks!


"Hezekiel" <tilaus@almasoftware.com> wrote in message
news:3755035.1076078717313.JavaMail.itn@is.intellij.net...

I tried 1144 with 1.5.0 beta. Idea starts nicely but I can't open my

source files for editing.


0


I just tested this and would like to confirm that a somewhat non-intuitive
setting will allow generics to work.

To clarify Alexey's slightly cryptic comment, I did the following:

- disabled "Use generics-enabled compiler"

- used "-source 1.5" in "Additional javac command line parameters"

Changing either of these caused problems. Clearly the "Use generics..." is
really "Add generics support to a pre-1.5 compiler".

Anyway, I am happy now.


Alexey Efimov wrote:

Build 1144 work with 1.5.0-beta very well, however Aurora is "Official
Unsupported JDK 1.5" before 4.1.

I use, JDK 1.5.0-beta (build 1.5.0-beta-b31), IntelliJ IDEA build 1141, in
libraries i have NOT any generics jars (collect.jar, gjc-rt.jar), in
compiler settings i have unchecked "Use generics-enabled compiler", and
"-source 1.5" in "Additional Javac command line parameters".


0

Please sign in to leave a comment.