Too many open files error after installing IntelliJ 9M1 (buildid #10781)

I'm not sure if this is the right please to post issues/bugs with IntelliJ but I think I will hear if it isn't :-)

After installing the new version of IntelliJ 9M1 on my linux Fedora release 11

It start opening my last project and after while I get a lot of 'to many open files' error. I copied one of them here below:

[ 402108]  ERROR - - IntelliJ IDEA (Maia) #10781  Build #10781
[ 402108]  ERROR - - JDK: 1.6.0_14
[ 402108]  ERROR - - VM: Java HotSpot(TM) 64-Bit Server VM
[ 402108]  ERROR - - Vendor: Sun Microsystems Inc.
[ 402108]  ERROR - - OS: Linux
[ 402108]  ERROR - - Last Action: $Delete
[ 402184]  ERROR - - /home/cvw/.IntelliJIdea90/system/caches/records.dat.len (Too many open files) /home/cvw/.IntelliJIdea90/system/caches/records.dat.len (Too many open files)
    at Method)
    at com.intellij.openapi.vfs.newvfs.persistent.FSRecords$DbConnection.flushSome(
    at com.intellij.openapi.vfs.newvfs.persistent.FSRecords$DbConnection$
    at java.util.concurrent.Executors$
    at java.util.concurrent.FutureTask$Sync.innerRunAndReset(
    at java.util.concurrent.FutureTask.runAndReset(
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(
    at java.util.concurrent.ScheduledThreadPoolExecutor$
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
    at java.util.concurrent.ThreadPoolExecutor$

Comment actions Permalink

I'm also on 64 Bit Fedora 11.

I'm using Sun Java 1.6.11

I run into similar errors when trying to run my application in a local tomcat.

(Too many files open)

I'm now using the lastest version 90.122

When I run into this error, I can't send the error report for the same reason, too many files open.

Comment actions Permalink

I fixed this by adding these two lines to the bottom of


Add these two lines (the * is required)

*    hard nofile 65535
*    soft nofile 65535

Comment actions Permalink

I got same problem while working with groovy. I filed an issue:

Touching /etc/security settings sounds more like a workaround.


Please sign in to leave a comment.