Too many open files error after installing IntelliJ 9M1 (buildid #10781)

I'm not sure if this is the right please to post issues/bugs with IntelliJ but I think I will hear if it isn't :-)

After installing the new version of IntelliJ 9M1 on my linux Fedora release 11
kernel: 2.6.30.8-64.fc11.x86_64

It start opening my last project and after while I get a lot of 'to many open files' error. I copied one of them here below:

[ 402108]  ERROR - j.util.io.ResizeableMappedFile - IntelliJ IDEA (Maia) #10781  Build #10781
[ 402108]  ERROR - j.util.io.ResizeableMappedFile - JDK: 1.6.0_14
[ 402108]  ERROR - j.util.io.ResizeableMappedFile - VM: Java HotSpot(TM) 64-Bit Server VM
[ 402108]  ERROR - j.util.io.ResizeableMappedFile - Vendor: Sun Microsystems Inc.
[ 402108]  ERROR - j.util.io.ResizeableMappedFile - OS: Linux
[ 402108]  ERROR - j.util.io.ResizeableMappedFile - Last Action: $Delete
[ 402184]  ERROR - j.util.io.ResizeableMappedFile - /home/cvw/.IntelliJIdea90/system/caches/records.dat.len (Too many open files)
java.io.FileNotFoundException: /home/cvw/.IntelliJIdea90/system/caches/records.dat.len (Too many open files)
    at java.io.FileOutputStream.open(Native Method)
    at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
    at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
    at com.intellij.util.io.ResizeableMappedFile.writeLength(ResizeableMappedFile.java:65)
    at com.intellij.util.io.ResizeableMappedFile.force(ResizeableMappedFile.java:92)
    at com.intellij.openapi.vfs.newvfs.persistent.FSRecords$DbConnection.flushSome(FSRecords.java:55)
    at com.intellij.openapi.vfs.newvfs.persistent.FSRecords$DbConnection$3.run(FSRecords.java:6)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
    at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
    at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:181)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:205)
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
    at java.lang.Thread.run(Thread.java:619)

3 comments
Comment actions Permalink

I'm also on 64 Bit Fedora 11.

I'm using Sun Java 1.6.11

I run into similar errors when trying to run my application in a local tomcat.

(Too many files open)

I'm now using the lastest version 90.122

When I run into this error, I can't send the error report for the same reason, too many files open.

0
Comment actions Permalink

I fixed this by adding these two lines to the bottom of

/etc/security/limits.conf

Add these two lines (the * is required)

*    hard nofile 65535
*    soft nofile 65535

0
Comment actions Permalink

I got same problem while working with groovy. I filed an issue: http://youtrack.jetbrains.net/issue/IDEA-25592

Touching /etc/security settings sounds more like a workaround.

0

Please sign in to leave a comment.