Help with Intellij and JUnit configuration

Hi, I have problems configuring Intellij and JUnit, I am working on an Spring project, so I am using spring-test for the JUnit integration, but my problem is not with the framework, is with the Intellij configuration.

Every time I try to run the unit test I get this error:

/usr/lib/jvm/java-6-sun-1.6.0.16/bin/java -classpath /xxxPath/lib/incontact-admin-test.jar:/xxxPath/lib/junit-4.4.jar:/xxxPath/lib/spring-test.jar:/xxxPath/lib/idea_rt.jar -Didea.launcher.port=7538 -Didea.launcher.bin.path=/xxxPath/idea-IU-90.94/bin -Dfile.encoding=UTF-8 com.intellij.rt.execution.application.AppMain com.intellij.rt.execution.junit.JUnitStarter -ideVersion5 @@/tmp/junitlisteners3164954303242947071 @/tmp/idea_junit2651228636372744029.tmp

Error: java.io.FileNotFoundException: @/tmp/junitlisteners3164954303242947071 (No such file or directory)

Process finished with exit code 1


Is annoying because is not even an error on my code, someone have any idea of how can I fix this?

By the way I am using Idea 9 EAP

Thanks!

2 comments
Comment actions Permalink

Hello Jonathan,

Which build do you use?

Thank you
-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

Hi, I have problems configuring Intellij and JUnit, I am working on an
Spring project, so I am using spring-test for the JUnit integration,
but my problem is not with the framework, is with the Intellij
configuration.

Every time I try to run the unit test I get this error:

 /xxxPath/lib/incontact-admin-test.jar:/xxxPath/lib/junit-4.4.jar:/xxxP
> ath/lib/spring-test.jar:/xxxPath/lib/idea_rt.jar
> -Didea.launcher.port=7538
> -Didea.launcher.bin.path=/xxxPath/idea-IU-90.94/bin
> -Dfile.encoding=UTF-8 com.intellij.rt.execution.application.AppMain
> com.intellij.rt.execution.junit.JUnitStarter -ideVersion5
> @@/tmp/junitlisteners3164954303242947071
> @/tmp/idea_junit2651228636372744029.tmp
> 
> Error: java.io.FileNotFoundException:
> @/tmp/junitlisteners3164954303242947071 (No such file or directory)
> 
> Process finished with exit code 1
> ]]>

Is annoying because is not even an error on my code, someone have any
idea of how can I fix this?

By the way I am using Idea 9 EAP

Thanks!

---
Original message URL:
http://www.jetbrains.net/devnet/message/5247639#5247639



0
Comment actions Permalink

I am using the lastest idea EAP version (build 90.94), junit-4.4 and I use ant to build the proyect, so, I have an custom output path, no the one generate it by Intellij.

0

Please sign in to leave a comment.