once again jsp tags

Hi,

There was ton of reports on tags not working inside jsp, so do not remember if this one was reported, but I am not able to find one.

The following code in jsp is highlighted in red
]]>

the foo is the String object set in my action.
The read highlighting is in the second line under foo.

Similar problem exists with Struts iterate tag.

]]>

In this example the "index" is highlighted as en error.

It looks like IDEA is wrongly recognizing variables defined inside tags in the scriplet code.

When I mouseover the error I have information "Cannot resolve symbol 'blahblah'".

Except this there is no other errors on the page, so I presume that I set it up just fine. Before when I play with setup I have more errors including "cannot resolve the symbol" on the tag import. Now all the imports are OK.

Any help will be appreciated..

Jerzy Puchala

6 comments

I see this as well when using struts.

--Grant


"Jerzy Puchala" <no_mail@jetbrains.com> wrote in message
news:31778359.1075400956477.JavaMail.itn@is.intellij.net...

Hi,

>

There was ton of reports on tags not working inside jsp, so do not

remember if this one was reported, but I am not able to find one.
>

The following code in jsp is highlighted in red
> > > > ]]>

>

the foo is the String object set in my action.
The read highlighting is in the second line under foo.

>

Similar problem exists with Struts iterate tag.

>

> > > > > ]]>

>

In this example the "index" is highlighted as en error.

>

It looks like IDEA is wrongly recognizing variables defined inside tags in

the scriplet code.
>

When I mouseover the error I have information "Cannot resolve symbol

'blahblah'".
>

Except this there is no other errors on the page, so I presume that I set

it up just fine. Before when I play with setup I have more errors including
"cannot resolve the symbol" on the tag import. Now all the imports are OK.
>

Any help will be appreciated..

>

Jerzy Puchala



0

I have a similar situation. I went from 1108 to 1126 (with an "import
settings" install) and all my JSP pages now have numerous syntax errors
stemming from two problems:

--all statements fail --all refererences to taglibs fail I've played around with the web module config settings but nothing seems to work. I say "played around with" because it's not entirely intuitive what settings will fix this problem. Setting up a Web Resources Directory didn't fix it. This problem seems to be a recurring theme throughout the latest EAP. I am somewhat confused why such a simple concept as "here is where I have these files....please go reference them" is still a problem. ??? "Jerzy Puchala" ]]> wrote in message
news:31778359.1075400956477.JavaMail.itn@is.intellij.net...

Hi,

>

There was ton of reports on tags not working inside jsp, so do not

remember if this one was reported, but I am not able to find one.
>

The following code in jsp is highlighted in red
> > > > ]]>

>

the foo is the String object set in my action.
The read highlighting is in the second line under foo.

>

Similar problem exists with Struts iterate tag.

>

> > > > > ]]>

>

In this example the "index" is highlighted as en error.

>

It looks like IDEA is wrongly recognizing variables defined inside tags in

the scriplet code.
>

When I mouseover the error I have information "Cannot resolve symbol

'blahblah'".
>

Except this there is no other errors on the page, so I presume that I set

it up just fine. Before when I play with setup I have more errors including
"cannot resolve the symbol" on the tag import. Now all the imports are OK.
>

Any help will be appreciated..

>

Jerzy Puchala



0

Hi All!

All these symptoms mean that you don't have your web module set up
properly. Please follow these instructions to set up your project:
http://www.intellij.org/twiki/bin/view/Main/WebModules

IK

Michael Morett wrote:

I have a similar situation. I went from 1108 to 1126 (with an "import
settings" install) and all my JSP pages now have numerous syntax errors
stemming from two problems:

--all<jsp:include> statements fail
--all refererences to taglibs fail

I've played around with the web module config settings but nothing seems to
work. I say "played around with" because it's not entirely intuitive what
settings will fix this problem. Setting up a Web Resources Directory didn't
fix it.

This problem seems to be a recurring theme throughout the latest EAP. I am
somewhat confused why such a simple concept as "here is where I have these
files....please go reference them" is still a problem.

???

<sigh>


"Jerzy Puchala" <no_mail@jetbrains.com> wrote in message
news:31778359.1075400956477.JavaMail.itn@is.intellij.net...

>>Hi,
>>
>>There was ton of reports on tags not working inside jsp, so do not


remember if this one was reported, but I am not able to find one.

>>The following code in jsp is highlighted in red
>>> >> >> >> >>]]>
>>
>>the foo is the String object set in my action.
>>The read highlighting is in the second line under foo.
>>
>>Similar problem exists with Struts iterate tag.
>>
>>> >> >> > indexId="index" > > >> >> >>]]>
>>
>>In this example the "index" is highlighted as en error.
>>
>>It looks like IDEA is wrongly recognizing variables defined inside tags in


the scriplet code.

>>When I mouseover the error I have information "Cannot resolve symbol


'blahblah'".

>>Except this there is no other errors on the page, so I presume that I set


it up just fine. Before when I play with setup I have more errors including
"cannot resolve the symbol" on the tag import. Now all the imports are OK.

>>Any help will be appreciated..
>>
>>Jerzy Puchala




--
Igor Kuralenok
Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0

This brings up a sticky question.

I have been using EAP builds, but my co-workers have not. What do you
recommend they do for their projects? I am under the impression that they
will not convert "with pleasure".

--
Norris Shelton
Sun Certified Java Programmer


"Igor Kuralenok (JetBrains)" <ik@intellij.com> wrote in message
news:bvlrj2$k7i$1@is.intellij.net...

Hi All!

>

All these symptoms mean that you don't have your web module set up
properly. Please follow these instructions to set up your project:
http://www.intellij.org/twiki/bin/view/Main/WebModules

>

IK

>

Michael Morett wrote:

I have a similar situation. I went from 1108 to 1126 (with an "import
settings" install) and all my JSP pages now have numerous syntax errors
stemming from two problems:

>

--all<jsp:include> statements fail
--all refererences to taglibs fail

>

I've played around with the web module config settings but nothing seems

to

work. I say "played around with" because it's not entirely intuitive

what

settings will fix this problem. Setting up a Web Resources Directory

didn't

fix it.

>

This problem seems to be a recurring theme throughout the latest EAP. I

am

somewhat confused why such a simple concept as "here is where I have

these

files....please go reference them" is still a problem.

>

???

>

<sigh>

>
>

"Jerzy Puchala" <no_mail@jetbrains.com> wrote in message
news:31778359.1075400956477.JavaMail.itn@is.intellij.net...

>
>>Hi,
>>
>>There was ton of reports on tags not working inside jsp, so do not
>

remember if this one was reported, but I am not able to find one.

>
>>The following code in jsp is highlighted in red
>> >> > >> > >> > >> > >>]]>
>>
>>the foo is the String object set in my action.
>>The read highlighting is in the second line under foo.
>>
>>Similar problem exists with Struts iterate tag.
>>
>> >> > >> > >> > > > indexId="index" > > > > >> > >> > >>]]>
>>
>>In this example the "index" is highlighted as en error.
>>
>>It looks like IDEA is wrongly recognizing variables defined inside tags

in

>

the scriplet code.

>
>>When I mouseover the error I have information "Cannot resolve symbol
>

'blahblah'".

>
>>Except this there is no other errors on the page, so I presume that I

set

>

it up just fine. Before when I play with setup I have more errors

including

"cannot resolve the symbol" on the tag import. Now all the imports are

OK.

>
>>Any help will be appreciated..
>>
>>Jerzy Puchala
>
>
>

>
>

--
Igor Kuralenok
Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

>


0

Norris Shelton wrote:

This brings up a sticky question.

I have been using EAP builds, but my co-workers have not. What do you
recommend they do for their projects? I am under the impression that they
will not convert "with pleasure".

As far as I know there will be (is) a convertor for 3.0 projects.

IK

--
Igor Kuralenok
Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0

Fantastic, thx. I'm sure they will be happy-upgraders.

--
Norris Shelton
Sun Certified Java Programmer


"Igor Kuralenok (JetBrains)" <ik@intellij.com> wrote in message
news:bvm0e8$m9r$1@is.intellij.net...

Norris Shelton wrote:

This brings up a sticky question.

>

I have been using EAP builds, but my co-workers have not. What do you
recommend they do for their projects? I am under the impression that

they

will not convert "with pleasure".

As far as I know there will be (is) a convertor for 3.0 projects.

>

IK

>

--
Igor Kuralenok
Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

>


0

Please sign in to leave a comment.