AspectJ support

Using: Build 1074
OS: Win XP Professional

How does one take advantage of the AspectJ support that is available in
IDEA? I am finding that when I create a new Aspect (Context Menu: New >
Aspect) it is highlighted as an error. The name is highlighted with the
message : 'class' or 'interface' expected. As you go along, everything
else, the pointcut, the advice is shown as being in error.

I suspect I am missing some fundamental step.

Sri


3 comments

The AspectJ support is postponed for version 4.0

--

Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc
http://www.jetbrains.com
"Develop with pleasure!"



0

Hey, if I cant get simple taglib and jsp:include support, you cant have
AspectJ.

:)


"Sri Sankaran" <sri.sankaran@sas.com> wrote in message
news:bvbo3a$i91$1@is.intellij.net...

Using: Build 1074
OS: Win XP Professional

>

How does one take advantage of the AspectJ support that is available in
IDEA? I am finding that when I create a new Aspect (Context Menu: New >
Aspect) it is highlighted as an error. The name is highlighted with the
message : 'class' or 'interface' expected. As you go along, everything
else, the pointcut, the advice is shown as being in error.

>

I suspect I am missing some fundamental step.

>

Sri

>
>


0

Please sign in to leave a comment.