Installing build 10781 affects 8.1.3?

Yesterday I installed the EAP build 10781 and now when I try to use 8.1.3 I get crazy IntelliJ drawing issues. The screen isn't fully drawn, the gutters aren't drawn, etc. Two screen shots attached. The editor won't draw until the cursor reaches each line. Is this related to installing 10781? I can't imagine it does but it defintely corresponded with the install of 10781 (never had this issue before). 10781 does not suffer from this.
I have since removed 10781 but the problem remains.
Screen shot 2009-10-06 at 10.46.15 AM.png

Screen shot 2009-10-06 at 10.44.59 AM.png

7 comments
Comment actions Permalink

Here is another screenshot that shows the toolbar not drawing (until you mouse over a toolbar icon):

Screen shot 2009-10-06 at 10.56.23 AM.png

0
Comment actions Permalink

Hello Michael,

This can happen if you use 10781 and 8.1.3 with the same project files. The
problem should be fixed in the latest 8.1.4 EAP build:
http://www.jetbrains.net/confluence/display/IDEADEV/Diana+EAP

Yesterday I installed the EAP build 10781 and now when I try to use
8.1.3 I get crazy IntelliJ drawing issues. The screen isn't fully
drawn, the gutters aren't drawn, etc. Two screen shots attached. The
editor won't draw until the cursor reaches each line. Is this related
to installing 10781? I can't imagine it does but it defintely
corresponded with the install of 10781 (never had this issue before).
10781 does not suffer from this.
I have since removed 10781 but the problem remains.
Image:Screen shot 2009-10-06 at 10.46.15 AM.png
Image:Screen shot 2009-10-06 at 10.44.59 AM.png

---
Original message URL:
http://www.jetbrains.net/devnet/message/5246488#5246488

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks for the information. Re-creating the project files seems to have fixed it.

Making a guess that 8.1.3 is reading from the file on the Event Dispatcher Thread and throwing an exception due to some 10781 additions? Reading from the file on the EDT...hmm, that's naughty ;-)

0
Comment actions Permalink

Well I take that back. Re-creating the project files didn't fix it. When you say "project files" are you meaing the .ipr and .iml files? Or are you meaning the files in ~/.IntelliJIdea80 and ~/.IntellijIdea8x?

0
Comment actions Permalink

Is there anything I can do to fix this without installing another EAP?

0
Comment actions Permalink

I have deleted my .IntellijIdea80 and .IntellijIdea8x directories yet the problem remains. Which files do I need to delete and recreate to fix this issue?

0
Comment actions Permalink

From http://jetbrains.net/jira/browse/IDEADEV-39016?disableRedirect :

%config%/options/other.xml, try removing the following sections:

<component name="InspectionProfileManager">
<component name="SeverityRegistrar">



See also: http://youtrack.jetbrains.net/issue/IDEA-24338

Bas
0

Please sign in to leave a comment.