TestNG Configuration Not Showing Up In Maia Build 10781

I installed the TestNG plug-in for Maia build 10781, but I don't see the TestNG configuration under Run/Build.  I can add JUnit successfully.  I annotated a test class using the TestNG annotations in my project /test source directory, but it never switched on the "TestNG" marking.

I'm running Maia 10781 on Windows XP Pro SP3 using Sun's JDK 1.6.0_13.

6 comments
Comment actions Permalink

What do you mean by "installing the testng plugin" - since IDEA 7 the plugin has shipped -with- IntelliJ - there should be no need to manually install it.

0
Comment actions Permalink

Hi Mark,

I could see the JUnit icon when I opened the Run->Edit Configurations drop-down, but not TestNG.  I assumed, perhaps incorrectly, that I needed to download and install the TestNG plugins.  

You're right about it being available in earlier versions.  I can see "TestNG" as an option in an earlier version of IntelliJ that I have installed.  

How can I get it back for build 10781 of Maia?  

0
Comment actions Permalink

Check that the "TestNG-J" plugin is installed and enabled in
File->Settings->Plugins.

-tt

0
Comment actions Permalink

Installed and enabled, but still no TestNG option in my configurations.

0
Comment actions Permalink

Hello Michael,

Could you please check that you do not have
  1. TestNG plugin in USER_HOME/.IntelliJ IDEA9.x/config/plugins,
  2. exceptions in the log USER_HOME/.IntelliJ IDEA9.x/system/log/idea.log

If so could you please take a screenshot of your Run Configurations default
settings: Run|Edit Configurations|Edit Defaults

Thank you

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

Installed and enabled, but still no TestNG option in my
configurations.

---
Original message URL:
http://www.jetbrains.net/devnet/message/5246387#5246387



0
Comment actions Permalink

Hi Anna,

Thanks so much for taking the time to respond.  I think I'm all sorted out now, but I'm still mystified as to what I did wrong.  I took the easy way out by uninstalling and re-installing build 10781.  Of course TestNG was there after I re-installed, and all was well.

I must have done something to break the plug-in, but I couldn't swear in a court of law as to what I did.

Thanks again. - Michael

0

Please sign in to leave a comment.