License Collision

I get a license collision error when using Idea on multihomed machine (or
machines with VMWare and Virtual NIC cards).

This is a problem as the only way to stop the error is to disable the NIC
cards. This means that when I'm using an app server on my VMWare ghost OS I
can't access it from windows.

Thanks,
Kevin


6 comments

AFAIK IDEA sends the broadcast to check for the same license only at
startup. As a workaround, could you not disable the virtual NICs only
until you start IDEA and re-enable them after that?

HTH,
Andrei

On Tue, 09 Dec 2003 20:03:49 -0600, Kevin E. Breidenbach wrote:

I get a license collision error when using Idea on multihomed machine (or
machines with VMWare and Virtual NIC cards).

This is a problem as the only way to stop the error is to disable the NIC
cards. This means that when I'm using an app server on my VMWare ghost OS
I can't access it from windows.

Thanks,
Kevin


0

Is it problem of the latest build or you did experience it before?

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

"Kevin E. Breidenbach" <me@nospam.com> wrote in message
news:br5urs$moi$1@is.intellij.net...

I get a license collision error when using Idea on multihomed machine (or
machines with VMWare and Virtual NIC cards).

>

This is a problem as the only way to stop the error is to disable the NIC
cards. This means that when I'm using an app server on my VMWare ghost OS

I

can't access it from windows.

>

Thanks,
Kevin

>
>


0

Valentin Kipiatkov (JetBrains) wrote:

Is it problem of the latest build or you did experience it before?


It started with 922. I'm seeing the same thing (with VMware installed).

If I manually disable VMware's virtual network cards then it works just
fine.

Maybe machines with multiple real network cards would have this problem
too, but I don't have one to test, sorry. :(

- Paul

0

This happens only on build 992. All previous versions were fine.

Thanks,
Kevin
"Valentin Kipiatkov (JetBrains)" <valentin@intellij.com> wrote in message
news:br7bo1$f0r$1@is.intellij.net...

Is it problem of the latest build or you did experience it before?

>

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

>

"Kevin E. Breidenbach" <me@nospam.com> wrote in message
news:br5urs$moi$1@is.intellij.net...

I get a license collision error when using Idea on multihomed machine

(or

machines with VMWare and Virtual NIC cards).

>

This is a problem as the only way to stop the error is to disable the

NIC

cards. This means that when I'm using an app server on my VMWare ghost

OS

I

can't access it from windows.

>

Thanks,
Kevin

>
>

>
>


0

I am currently using build #1071 with my usual license key and this occasionally has the same problem.

I develop on a laptop that has a built-in wifi connection. Occasionally intellij will detect the collision and that means I have to disable the wifi access and start again. It is only an occasional problem, sometimes it works fine.

Once started a can enable my wifi again (often I don't as I have left in on by mistake!).

Would be better if the license checking routing iterated through all of the ip adddresses on the machine to detect if the collision was valid.

Cheers,

Martin.

0

Please upgrade to the latest version. This bug has been fixed.

0

Please sign in to leave a comment.